• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS ADE 2020 Alpha 18 Released

Hi Jon, not so happy about the things I can read here; "breaking changes" ... "not backward compatible"; but always happy with Alpha 17, except: Did you try to fix the Runway Start Inversion issue of Alpha 15, which still persists in Alpha 17? The problem could be a result of the compiling process, since the XML seems to be correct.
I am sorry about 'breaking changes' but this is an alpha development so it is bound to happen. Once we get to beta that should stop. Can you please remind me what the start inversion issue is please - I have a lot of things on the work list.
 
I am having the same problem with shifted customer models which I have imported from version Alpha17

As explained this can be fixed by recreating the footprints for you user models. Go to List > Models an click the Get Footprints button. This should recreate them. Save and close ADE after you do that and when you restart they should be back to the same as alpha 17. I assume you have updated with the Hotfix 1?
 
Alpha 18 hotfix 2 is now available from the top post in this thread. It is cumulative and includes the fixes from Hotfix 1 plus a fix to correct the display orientation for library objects.
 
Alpha 18 hotfix 2 is now available from the top post in this thread. It is cumulative and includes the fixes from Hotfix 1 plus a fix to correct the display orientation for library objects.
Thanks for your efforts, again.
Does this hotfix2 includes the correction of user models, also ?
 
Yes it should but the issue with user models is that not everyone designs them to the same orientation so some may still behave badly. It works on the ones I have tested. If you have any issues then please send me some samples
 
Yes it should but the issue with user models is that not everyone designs them to the same orientation so some may still behave badly. It works on the ones I have tested. If you have any issues then please send me some samples
Yes, tested after hotfix2 and user models are also displayed in the correct orientation in MSFS. Thank you.
 
Hi,
Using ver. 18, trying to import a new model and get the following error (I tried the send log thing but got CTD)

System.NullReferenceException: Object reference not set to an instance of an object.
at ScruffyDuck.AirportDesignEditor.Repositories.ModelFootprintGenerator.GetTriangles(Boolean useReplace, Model model)
at ScruffyDuck.AirportDesignEditor.Listers.Lister.AddModel()
at ScruffyDuck.AirportDesignEditor.Listers.Lister.OnAddButtonClick(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

This comes up as soon as I press "save"

Regards

Steve
 
please install the hotfix listed in the first post of this thread
 
OK, can you send me the model that is causing the problem. is it just one model or any model?
 
Hi Jon,
It's only this file at the moment.

Steve
Works here - I can add it to ADE without error. Looks like this in the display when added

1616667738747.png


Can you take a screen shot of your About Box in ADE

1616667811034.png
 
Alpha 18 Hotfix 3 is now available. Please see first post in this thread for details and download link
 
This is a significant update to the last alpha. It contains breaking changes. These mean that certain things work in a way that is not backward compatible with earlier versions. Because of this you need to create a new installation for alpha 18. Do not install it over an earlier version and do not share projects with it and earlier versions. Make copies of your projects to use with alpha 18. The application is now 64bit which means ADE has access to much more memory and should therefore no generate Out of Memory Errors. If you still get them then please report it.

Summary of changes

Added

  • Max wingspan allowed ring for parking spaces. This is something that appears to be used in MSFS and if the outer rings overlap then planes may not park next to each other
  • More SimObjects that can be added by ADE
Updated
  • Handling of detailed object footprints generation and storage. This is a breaking change
  • Handling of libraries in the Library Object Manager to allow libraries with the same name to be added or updated (uses the full path name rather than the file name). This is a breaking change
  • ADE is now a 64bit application with better memory capabilities
  • Jetway handling (may be breaking changes)
    • DeleteAllJetways is now set to true by default
    • Delete Parking Spot deletes Jetway
    • Edit to Parking Spot reflected automatically into Jetway including suffix
    • Move/rotate editing of placement
    • New jetway with selection of connector type
    • Automatic selection of Connector Type based on distance from building to Jetway SimObject End
Fixed
  • CTD when opening taxi point list.
  • Out of memory errors by updating ADE to 64bit (Thanks to Dick for his help)
  • Name and typing of Parking Spot
  • Send log not sending the current project
Removed
  • Disabled Load Last Project in Settings since it loads only the ADE project and not the MSFS Project.
  • Disabled Copy to Community Folder Dialog.

Installation and breaking changes

Make a fresh install. Make copies of any project you wish to use in alpha 18. The breaking changes are

Handling of Detailed Footprints and Handling of Libraries in the LOM

The database used to store footprints is generating errors and it is no longer supported by the developer. ADE no longer uses the MFDB in the global folder and this is missing from Alpha 18. Instead footprints are stored as individual files. Aside from easier management this has reduced the disk space required to store footprints. If you have added your own library objects to the LOM then you will need to load them again for Alpha 18. Since MSFS allows the same library file name (eg modelLib.bgl) in different packages the LOM could not handle these. It can now but it means you will need to re add any personal libraries to the LOM.

Jetways

The handling of jetways has been changed considerably. This may be a breaking change for existing projects with jetways . If you have such projects then be sure to make a copy to use with Alpha 18. If you have issues with existing jetways in alpha 18 the you can probably fix it by creating a new project from the source XML file of the existing project.

Late Issues

A late bug in adding jetways. Do not right click inside the parking spot to create the jetway. It causes a malformed result. Click on the edge of the building that the jetway is to be attached to. Generally jetways are to the left side of the aircraft and ADE draws a new jetway in that orientation before it is edited


Download from here: https://www.mediafire.com/file/zp8gkmfkfl6ym31/ade_2020_alpha_18_Installer.zip/file

HOTFIX 1
This hotfix file contains fixes for the Send Log and Custom glTF Models bugs.

HOTFIX 2
This hotfix file is cumulative and contains the fixes from Hotfix 1 and corrects the orientation of library objects .

HOTFIX 3
Cumulative update includes fixes from HF1 and HF2. Also:
  • Restored Copy to Community Folder for MS Edition users. This is optional and can be set in Settings > Options > General Tab
  • Updated display of Property Grid so that it now opens in all circumstances. (This to avoid errors and CTDs with the Common Property Dialog) It will open with Enter, Ctrl+Enter and so on. This can be turned off in Settings > Options > General Tab but it is strongly recommended to use the Property Grid to stop issues
  • Undo is now available for changes made in the Property Grid.
  • Send Log will now check the size of the project folder before attempting to send it (max 30Mb uncompressed)
  • Fix for duplicated parking index numbers

Copy the contents into the current alpha 18 installation folder. You need to do this while this message is present in this post. Later the main installer will be updated
Jon, Thank You. Progressing right along!
 
Works here - I can add it to ADE without error. Looks like this in the display when added

View attachment 71190

Can you take a screen shot of your About Box in ADE

View attachment 71191
Versions:

Application 20.18.7750.12041
Engine 20.00.7749.27193

Acknowledgements:

ADE Development Team
The CodeProject Community
The Stack Overflow Community

University of Maryland - Piccolo Graphics Engine
Paul Henty - FSUIPC Client DLL for .NET
Don Grovestine - Custom Ground Polys
Arno Gerretsen - Models Handling
Matt Johnson - XML Sources

Sorry, it was easier to copy and paste!

Steve
 
Versions:

Application 20.18.7750.12041
Engine 20.00.7749.27193

Acknowledgements:

ADE Development Team
The CodeProject Community
The Stack Overflow Community

University of Maryland - Piccolo Graphics Engine
Paul Henty - FSUIPC Client DLL for .NET
Don Grovestine - Custom Ground Polys
Arno Gerretsen - Models Handling
Matt Johnson - XML Sources

Sorry, it was easier to copy and paste!

Steve

I am sorry but since I cannot replicate it I am not currently able to offer a solution
 
I am sorry but since I cannot replicate it I am not currently able to offer a solution
Thanks for trying.

Ive found a way around it. I used Ver 17 to include the model, then opened the project in Ver 18 HF3, and it is now in...... shame I hadn't finished the model, so will have to go through that again! :)

Steve
 
After Installing hotfix3 in some of my projects I could generate my footprints, but in some others I get the error : you have a missing modelfile ..
Every project was working up to alpha17. What else is missing ?

Kalle
 
Can you provide a screenshot of the error message?
 
Back
Top