• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

AI Flight Planner (Version 1.0) - Report Bugs and Other Issues Here

Status
Not open for further replies.
Don,

Thks for yr answer

I did find something else that can be confusing.

I make a FP in individual mode, FSX days, local time summer and save the file set and close the program.

When I open the file set it opens in local time, standard. The flight times are one hour early (correct as input was summertime).Airport timezones correct. see attachment 1.

When I change to local time, summertime the flight times are adapted and correct (as input was summertime) but when I look at the airports in FP the timezones are wrong. EETN should be UTC3 and LEBL UTC2. see attachment 2.

This probably also has to do with the elusive bug...

Rgds
Luc
 

Attachments

  • 1.JPG
    1.JPG
    99.7 KB · Views: 401
  • 2.JPG
    2.JPG
    99.8 KB · Views: 454

gadgets

Resource contributor
Thanks again, Luc.

This probably also has to do with the elusive bug...
No, it's a different bug. When I added the summer time capability, I simply forgot to update the airport list when the time selection was changed. Same with the start-up condition. Both will be fixed in the next release (early next week).

Don
 
Consolidate

Don,

Thks for version 1.06.

When I work in consolidate mode the error message of dep airport and des airport is no longer there. Thks

I have done some further testing. I work in FSX days, lt summer, consolidate mode and have a flight on monday and wednesday (0 and 2 in FSX days). I save the file, open the file and doubleclick on the fp in fp list

1. consolidate mode is not activated and I have my flights double. I click on consolidate mode, everything correct again. I deactivate consolidate again and everything stays correct

2. the days are wrong. My flights are now on tuesday and thursday (1 and 3) although I am in FSX mode. Conclusion : even if you use FSX mode the plans are saved in FS9 mode as 1 and 3 are monday and wednesday in FS9........

3. When I open my flightplan again summertime is not activated

In individual mode I do not have problem 1 and 2

My ini file (after saving the fp) is attached

Rgds
Luc
 

Attachments

  • AIFP.txt
    505 bytes · Views: 445

gadgets

Resource contributor
Luc, I have found the problem regrading the flight plan not opening in the consolidated mode and it is easily fixed. In the meantime, you can safely re-select the consolidate mode using the checkbox.

I have also found a problem whereby if you change the day-encoding radio buttons, the latest selection is not reflected in the departure times in the leg list. (Only the DOW indicators are updated.) When the leg list is eventually saved back to the flight plan list, it's wrong. While this doesn't exactly duplicate the problem you're having, is likely associated with it. I'll check further as I'm working on it.

I'll have an update fixing these two problems later today.

I've not been successful yet in tracking down the "summertime issue". Just to be sure, did you at any time de-select summer time? The settings in the AIFP.ini file are only looked at at system startup, not on every flight plan load.

Don
 

gadgets

Resource contributor
Luc, a new release containing fixes for the problems you reported earlier has been uploaded here.

I was eventually able to duplicate everything you reported except the day numbers changing from 0 and 2 to 1 and 3. The only way I can envisage that happening is if you accidentally clicked on the Change Day Code button instead of one of the radio buttons. Clicking on the radio buttons changes the interpretation of the day numbers in weekly flight plans, but does not change the numbers themselves. Clicking on the Change Day Code button changes the day numbers in the flight plan up or down (depending on the current radio button selection) by 1. However, that day-number change was not carried over into the flight plan in the Leg List which, when saved, would cause the Flight Plan List to also be in error.

Sure wish you'd been on the beta team.

Don
 
Hi Don,

Thks for the corrections.

Regarding the day numbers changing I will describe what I do.
I start from a clean install (1.07).

1. Open AIFP
2. Start New FP
3. Day encoding FSX, Local Time Summer and Consolidate weekly FP
4. Add aircraft
5. Enter FP
6. Add FP to List
7. Open Text Editor

As you can seen from Attach 1 I have clearly choosen Monday and Wednesday but in the text editor it is 1 and 3 (Tuesday and Thursday in FSX but Monday and Wednesday in FS9..)

8. Save FP and close AIFP
9. Open AIFP and FP

As you can see in attach 2 the options are now correct (FSX days, LT Summer and consolidate but the days wrong (Tuesday and Thursday)

In have checked in the FlightPlans.txt and fsxdays = TRUE but day 1 and 3 instead of 0 and 2 (as entered in FP)

I have made special attention not to click on anything else during these steps and have done the same exercise twice with the same results

When I do the same exercise in individual mode the days are correct

Rgds
Luc
 

Attachments

  • 1.jpg
    1.jpg
    89.2 KB · Views: 381
  • 2.JPG
    2.JPG
    95.2 KB · Views: 405
  • FlightPlans Test.txt
    169 bytes · Views: 398

gadgets

Resource contributor
Got it!!! The FS9/FSX day-encoding radio button selection was not being taken into account when the edited flight plan was copied (back) into the Flight Plan List when in the weekly-consolidated mode.

Please try this one.

Don
 
Hi Don,

Works fine now.

I have found something else.

I enter a flight as follows (fsx days, local time summer)

dep : EVRA (UTC3)22:25
arr (calculated by AIFP) : UAAA (UTC7)07:24-1
flighttime is 04:59

Should this not be 07:24+1 ??? (dep + flighttime + 4 hrs time difference)

When I enter dep at 20:00 arr is 04:59+1 which is correct
When I enter dep at 20:01 arr is 05:00-1 which is not correct



Rgds
Luc



Thks a lot
Luc
 
Last edited:
AIFP error with own airportdesigns

hi Don,
I have designed 2 virtual airports EDBB and EDB2.
Together with my hometown airbase EHTW i wanted to make a little test FP, but i didn't succeed.

After filling in all the details when i push Add FP to list i get this error "no country/city for this airport".
Please see the attached images with all the details.
The airports involved are showing the country/city data.
Can you please give me a hint, where to look after this problem.

Regards
Bert
 
Last edited:

gadgets

Resource contributor
Should this not be 07:24+1 ??? (dep + flighttime + 4 hrs time difference)

When I enter dep at 20:00 arr is 04:59+1 which is correct
When I enter dep at 20:01 arr is 05:00-1 which is not correct
Luc, departures less than the time zone difference before midnight were not handled properly.

After filling in all the details when i push Add FP to list i get this error "no country/city for this airport".
Can you please give me a hint, where to look after this problem.
Bert, the problem was caused by you having entered a region when no other airports in Germany are regionalized (which you should be able to do).

Both problems are fixed in version 1.09.
 

Angelus1971

Resource contributor
Found a Bug in 1.09

HI

I double clicked the position information for an aiport in the "Get Airport Information" box and got this.



See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at WindowsApplication1.GetAirportInfo.TreeView1_AfterCheck(Object sender, TreeNodeMouseClickEventArgs e)
at System.Windows.Forms.TreeView.OnNodeMouseClick(TreeNodeMouseClickEventArgs e)
at System.Windows.Forms.TreeView.WmNotify(Message& m)
at System.Windows.Forms.TreeView.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
AI Flight Planner
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///D:/FSX%20Tools/AI%20Flight%20Planner/AI%20Flight%20Planner.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 

gadgets

Resource contributor
I double clicked the position information for an aiport in the "Get Airport Information" box and got an exception message.
Thanks for the report Angelus1971. It's a little problem I introduced yesterday while fixing another bug. It will not happen in the next release.

Glad it's all working for you now, Bert.

Don
 
Glad it's all working for you now, Bert.

Don

Hi Don,
Back again. After version 1.10 my accepted 2 virtual airports in v1.09 are still viewable in airport\edit add airport but when i want to add a change and/or compile i got an error report that the 2 airports don't exist in the airportlist.
My question now is; Am i not allowed to use virtual airports with AIFP anymore?

Regards
Bert
 

gadgets

Resource contributor
After version 1.10 my accepted 2 virtual airports in v1.09 are still viewable in airport\edit add airport but when I want to add a change and/or compile i got an error report that the 2 airports don't exist in the airportlist.
My question now is; Am i not allowed to use virtual airports with AIFP anymore?
Bert, AIFP doesn't know anything about virtual airports. If an airport has a valid ICAO code (as your two airports do), AIFP should use them. Since you can view them in the airport editor, that means they are in AirportList.dat. This suggests I only fixed part of the earlier problem.

Whenever you get a list of missing airports, there is often also an explanatory message referenced to the faulty flight plan/leg. Were there any such messages? If so, what did they say. As well, if you delete the "Region" using the Airport Editor, does the problem remain?

While waiting for your reply, I will continue looking for something else related to the problem you reported last week.

Don
 
Bert, AIFP doesn't know anything about virtual airports. If an airport has a valid ICAO code (as your two airports do), AIFP should use them. Since you can view them in the airport editor, that means they are in AirportList.dat. This suggests I only fixed part of the earlier problem.

Whenever you get a list of missing airports, there is often also an explanatory message referenced to the faulty flight plan/leg. Were there any such messages? If so, what did they say. As well, if you delete the "Region" using the Airport Editor, does the problem remain?

While waiting for your reply, I will continue looking for something else related to the problem you reported last week.

Don

hi Don,
You don't believe this. After reading your reply in this thread, i directly checked for your requests and....
nothing wrong at all:confused:
I really don't know what has caused this on-off problem.
I will come back when it comes again.
Sorry troubling you.
Regards.
Bert
 
Timezones

Hi Don,

There is stil something wrong with the calculation from lt to utc. I use version 1.11

I have following flight (lt) :

adep : EVRA (UTC3) 3/22:25
ades : UAAA (UTC7) 07:37+1 (calculated by AIFP), actual arrival acc timetable airline is 06:30+1

when I look at Flight Plan File Text Editor (utc) I see the FP as :

dep 3/19:25 (correct as 3/22:25 - 3hrs)
arr 2/23:30 (wrong as 4/06:30 - 7 hrs is 3/23:30)

see attachments

is the +1 from arr time not taken into account when doing the conversion from lt to utc ??

Rgds
Luc
 

Attachments

  • 1.JPG
    1.JPG
    68.9 KB · Views: 373
  • 2.JPG
    2.JPG
    30.5 KB · Views: 372
Status
Not open for further replies.
Top