• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

AIFP 3.4.0.5 Aircraft List

hi everyone, after upgrading from version 3.3.2.3 I am no longer able to add aircraft located outside the default directories (simobject p3dv4 or p3dv5).
reinstalling version 3.3.2.3 everything is ok.
any suggestions?
 

gadgets

Resource contributor
Since 3.3.2.3 is the latest general release, I assume you attempted to install Development Release 3.4.0.1. Please confirm. Also, could you be a little more forthcoming about the issue. What, exactly, is stopping you from adding new aircraft, i.e., at what point does the process fail? From where are you attempting to add them? You say things are OK when you reinstate 3.3.2.3. Do aircraft from outside the default directories previously added by 3.3.2.3 still appear in the aircraft list?
 
Since 3.3.2.3 is the latest general release, I assume you attempted to install Development Release 3.4.0.1. Please confirm.
confirm, 3.4.0.5 release
Also, could you be a little more forthcoming about the issue. What, exactly, is stopping you from adding new aircraft, i.e., at what point does the process fail? From where are you attempting to add them?
1) if I open a traffic txt saved file or a knowed bgl file, in the rh window "aircraft list" these are all red (missing). so if I try to substitude them through the "Select Substitute AI Tiltle" window it doesn't allow me to choose the directory where my ai models are, but it only allows me to choose those in the simulators directories (p3dv4 or p3dv5 or fs2020). you can see in attached screenshoots 1 and 2.
2) if I try to start a new flight plan for p3dv5, select the aircraft folder by path, then I choose the model, if I try to view it using the "Show Image" button an error appears: "No valid .mdl file found for this aircraft ". if I add the aircraft to the list anyway it does not appear red (missing) but if I reopen it via the aircraft editor there is no information about the aircraft!. u can see in attached screenshoots 3 and 4.
You say things are OK when you reinstate 3.3.2.3.
3) if I do the same operations with 3.3.2.3 release everything works fine: the aircraft are no longer missing, can add ai models from wherever I want, etc.
Do aircraft from outside the default directories previously added by 3.3.2.3 still appear in the aircraft list?
4) yes, with 3.3.2.3 release the aircraft list is correctly recognized again.

last note: if i use the the aircraft from the p3d simobject/airplanes "legacy" directory all work fine...

thank u and sorry for my english
 

Attachments

  • Screenshot 1.png
    Screenshot 1.png
    780.2 KB · Views: 29
  • Screenshot 2.png
    Screenshot 2.png
    594 KB · Views: 28
  • Screenshot 3.png
    Screenshot 3.png
    288.4 KB · Views: 31
  • Screenshot 4.png
    Screenshot 4.png
    224.8 KB · Views: 26
Last edited:

gadgets

Resource contributor
Thanks for the additional info. In your screenshot 2, you'll notice the "Select" radio button in the top row is disabled. It should not be for substitutions.

I can duplicate, so it should be easy to find the cause. Hopefully, fixing will be as easy.

Update probably tomorrow.

PS: If you add whatever folder that contains the missing aircraft to your PV5 simobjects.cfg, you can probably avoid the issue - something you will have to do anyway to use those aircraft in PV5.
 
thank you very much Don, yes the select button is disabled and I would prefer not to add my aircraft to the p3dv5 simobject.cfg file, in my simulator almost everything is set with add-on.xml files and everything works fine
 

gadgets

Resource contributor
Since you hadn't mentioned Addon.xml files, I had assumed the aircraft were in some "private" AI Aircraft folder. If the aircraft are in active add-on xml folders, then they are already registered with PV5. Consequently, its not clear why they didn't show up in the substitute dialog with PV5 selected.

Please confirm that is the case.
 
I confirm... sorry
as if the program didn't "read" the pv5 add-on.cfg file.
 

Attachments

  • Screenshot.png
    Screenshot.png
    848.3 KB · Views: 29
  • Screenshot 2.png
    Screenshot 2.png
    929.1 KB · Views: 24

gadgets

Resource contributor
From your screenshots, it appears that the Add-on.XML folders of interest are "buried" in your PV5\Scenery folder. If that is the case, they were found by the earlier version quite by accident, because I wasn't aware you could store add_on.xml folders in that location. I'll have a look at it tomorrow.
 
no, are not in the scenery folder ,.
what you see in the first screenshot is the reference to the traffic.bgl files given by the addon.xml.
in the second screenshot there are references to the other components such as simobjects, effects, etc. detected from the same addon.xml.
everything is correct, like the OCI-configuration addon.xml from AIG AI Manager (attached in txt format)
 

Attachments

  • add-on.txt
    1.3 KB · Views: 42
Last edited:

gadgets

Resource contributor
I've just made a new development release. (I found a typo ("C" vs "C:") which would have the effect you are observing.)
 
Top