• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS AIFP for MSFS

Hi good Morning,

Thanks a lot for your Flight Plan.

I put it in my community folder and it works as reported by yourself.
what I observed in addition: The flight is duplicated each time I load it. One of the duplicated DR-400 sinks into ground with one wheel. I didn't observe the random liveries, may be because I only have the standard livery.

I loaded your flight plan into AIFP. The main difference to my former attempts is: you made an IFR plan.
So I created an IFR plan for the dr400-140b Dauphin and for the MB339PAN from EDDE to EDDP and back. Great! Something is goning on:
- both aircraft visible on parking but doubled. i.e. have 4 planes now
- all aircraft being pushed back and start taxiing at the right time
- one of the DR-400 sink into ground with one wheel
- MB339s take off with canopy open
- 2nd loading: scenery stucks, DR-400 does not cross the holding position (may be that's an airport problem)

My resume:
All problems seem to be in FS2020, a lot of randomly behavior.
Except the splendid scenery al lot of missing or erroneous features which perfectly work in the predecessors since 20 years.
Before Asobo may fix all this they have to be aware of it, Who tells them.
 
I honestly haven't tested any flightplan until a take off yet. I thought that wouldn't be an issue.

I think (and this is just a wild idea) the duplicating may be due to the fact that the mod uses the base airliner for half its data?
I'm not sure, I had the duplicating too. But not if I use the ivao models. (these models don't use ingame models as a base)

They need to fix a couple of things before I continue indeed. I asked them to get in touch with AIG (and AIFP).
 
At this point I won't spend further time in this too. As I don't trust the stock airports I will now rework a simple Airport (in fact EDGE), one jet capable RWY, one simple taxi loop, few parkings.
Thanks again for your help so far!
 
Hello, I'm having the same issue jdiegel had earlier in the thread. I'm running the steam version of MSFS, but AIFP keeps trying to look in "E:\MS2020\official\OneStore" when the Steam version of the sim is actually installed in "E:\MS2020\official\Steam"

Eifvw6m.png
 

gadgets

Resource contributor
EDIT: Do not use the attached file - even if you are able to retrieve it
 
Last edited:

gadgets

Resource contributor
jDiegel in his note above stated MSFS was installed at "'E:\SteamLibrary\Official\Steam" But AIFP relies on the system registry to tell it where Flightsim is located, and that path includes only the first two elements of the path specified by jdiegel. Without further explanation, I assumed "\SteamLibrary" was placed there by the installer (as with FSX:SE") and keyed on it. So long as AIFP found "SteamLibrary" as the second element of the path reported from the System registry, the earlier fix worked. In Tuskin38's case, i.e., "E:\MS2020\official\Steam", this criteria was not met and AIFP resorted to "OneStore".

I should have a fix for this by end of day which will look for a folder named "pathFromRegistry\Official\Steam" and, if found, declare the installation to be "Steam"
 

gadgets

Resource contributor
Please give attached a try - but only if you currently have 3.4.1.5 installed
 

Attachments

  • AIFP3415(a).zip
    544.1 KB · Views: 44
Please give attached a try - but only if you currently have 3.4.1.5 installed
I'm getting the same error.

When you start the sim for the first time to download the files, you can choose any folder you want. Which is what I did to make it easier to access the files. That's why it isn't in my steam library folder.

I wonder if I have a leftover registry entry from when I had the MS Store version installed, because I also installed it to that same folder.
 
Last edited:

gadgets

Resource contributor
The initial fix for this issue was deficient, The current fix in 3415(a) will improve that situation, though apparently it's still not adequate for Tuskin 38.

AIFP first looks for a file named "UserCfg.opt" in whatever AppData folder is indicated as applicable to the user..
If not found, AIFP looks for a folder named "Packages" in the same AppData folder and then for a sub-folder named "Microsoft.FlightSImulator" containing UserCfg.opt

In either case the path to MSFS is assumed to be the contents of the included item (in UserCfg.opt"), "InstalledPackagesPath"

It seems clear given the deviation from past practices, by both Microsoft and Steam, that they were trying to discourage Add-ons. And, given the functional oversights in the early releases, I have little faith that the applicable uninstall routines would completely erase history - as would have been necessary in Tuskin28's case.

Anyone with real knowledge about MSFS registry handling, please review the above and comment as necessary. Tuskin38, if you can isolate and send me copies of the relevant registry entries in your system,. I'll try to figure out what's going on.
 
I actually can't seem to find any registry entry pointing to my install folder. I've searched the folder name and the path. Anyone know what the entry is actually called?

My UserCfg.opt file is in "AppData\Roaming\Microsoft Flight Simulator" and it is pointing to the folder I have it installed to.

Suggestion, maybe have two options that's like MSFS (MS Store) and MSFS (Steam)? And it just changes the name of the folder it's looking for? OneStore VS Steam.

I'm not a programmer so forgive me if that is harder than it sounds.
 
Last edited:

gadgets

Resource contributor
Unfortunately, it's not that simple. If this is a case of incomplete uninstall (as it appears), what's the next case going to look like?

When I referred to "system registry' I was referring to any file/folder/location involved in the location of the path to MSFS

Perhaps, for clarity, you could post a copy of your UserCfg.opt file
 

gadgets

Resource contributor
As you indicated, the file does show "E:\MS020 as the install path. And you have stated that the folder "E:\MS2020\official\Steam" not only exists but is also the installation location of MSFS2020.

If all that is true, then I don't understand why the fix I sent you doesn't work. Are you sure you installed it correctly? If you did, AIFP should identify itself in the opening screen title base as version 3.4.1.5(a). Please confirm.
 

gadgets

Resource contributor
The only other possibility I can think of is that the file path to MSFS2020 being returned to AIFP on your system is not "E:\MS2020".

The attached file with display the path returned
 

Attachments

  • AIFP3415(b).zip
    450.3 KB · Views: 35

gadgets

Resource contributor
That tells me what I need to know.

Please try the attached.
 

Attachments

  • AIFP3415(c).zip
    450.3 KB · Views: 52
Top