• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 All Lights render perfectly when starting at an airport but fail to do so when approaching an airport

Messages
14
Country
southafrica
I cannot fathom why AFLT lights fail to render when flying into an airport, but do so perfectly when starting a flight at an airport. I have spent many absorbing hours installing AFLT lights at a number of local airports and they are all there when I commence a flight, but I am stumped as to why P3D4.5 fails to load the lights as I approach an airport. What have I overlooked and is there a remedy?
 

tgibson

Resource contributor
Messages
10,710
Country
us-california
Do you have the little P3D AFLT app running in the background?
 
Messages
1,413
Country
germany
Exactly the same in FS2004:


Fly the approach at DUSK and wait until it changes to NIGHT. The lights (effects) will come.
 
Messages
14
Country
southafrica
Thank you for your response Tom. I don't remember whether the P3D AFLT was running in the background. However, after much searching and gnashing of teeth, I discovered that the problem was that the P3D Simconnect.dll had been blocked by Windows 10 because it had come from another computer. I unblocked the file and this solved the problem.
However, I now have a One is greater than Zero error coming up every time I start P3D. I have traced the problem to the effects.cfg file. I tried to solve the problem by turning this cfg file off, but this produced disastrous results in the sim. I am still puzzling over how to solve this problem and would greatly appreciate any help from those with the know-how.
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
However, I now have a One is greater than Zero error coming up every time I start P3D. I have traced the problem to the effects.cfg file. I tried to solve the problem by turning this cfg file off, but this produced disastrous results in the sim. I am still puzzling over how to solve this problem and would greatly appreciate any help from those with the know-how.

That error is most likely caused by an effects file (that was created by you.)
 

DragonflightDesign

Resource contributor
Messages
924
Country
northernireland
Check your min/max figures in your effects files. One of them will have the minimum figure set to be greater then the maximum figure - this will give the error you are seeing.
 
Messages
14
Country
southafrica
I have checked through all recent effects files and cannot see any disparities. There is an effects.cfg file in my Effects folder, which appears to be causing the One is greater than Zero error. It was installed with a repair of P3Dv4.5 Contents. How do I determine what settings in the effects.cfg are causing the one>zero error?
 
Messages
14
Country
southafrica
Hi All,
Thank you for trying to help. Clearly I don't understand exactly which figures in an fx file affect the one>zero error popup. Could someone please give me an example of problematic max/min figures, so I can see specifically what to look for. I presume the max/min figures in the effects.cfg file will not cause the error popup.
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Hello...
How many times do you have to click 'OK' at startup on this error? I'll show you what to look for later this day (early morning here ).

How many effects have you created?
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
In the picture below (surrounded in green). The Delay=10.00, 0.00 will cause an error stating 10.00 is greater than 0.00. You can have it as Delay= 0.00, 10.00. This goes for all parameters, I believe. So look where you have a 0.00 value at the end.

The 1st value is greater than the 2nd value is why the error..

min_max.png
 
Last edited:
Messages
14
Country
southafrica
Thank you Doug. At least I now know more specifically what to look for.

There's been a new twist to this saga of the error popup. Every fx file in the Effects folder of P3Dv4.5 has been tested by a process of elimination and not one of these files caused the error popup. What was discovered was that the effects.cfg file in the Effects folder is causing the error popup.

During the elimination testing, a new Effects folder was created (the original renamed to Effects.sav) and the fx_beacon.fx file and the effects.cfg file were the only two files in the new Effects folder. When this was tested in the sim, the error popup appeared. The fx file was removed, leaving only the effects.cfg file in place and again this was tested in the sim. Sure enough, there was the popup when the sim was started.

The contents of the effects.cfg file have been scrutinized against another from a different computer for possible error and nothing was amiss. For some unknown reason, the P3Dv4.5 installed in my computer does not like the effects.cfg file and I know too little about what this file interacts with in the sim to cause the error popup.

I'm hoping someone in the developer community will be able to help.
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Hello @Quentin Moore

You claimed that this "effects.cfg" file appeared after you had to repair P3Dv4.5. I don't think so since I never had to repair my P3D v4.5 and an "effect.cfg" file is present. That really doesn't matter at this time, but what I suggest you do is zip up the "effects.cfg" and send it to me by private message. This way I can compare it to mine.

Also, please include all effect .fx files that you have created or edited. What might have occurred is that you made changes or created an effect .fx file that is outside the limits of the effects.cfg file
 
Last edited:
Messages
14
Country
southafrica
Hello Doug. The effects.cfg file is only 3kb so I have attached it for your perusal, as I am not on facebook or twitter any longer.
 

Attachments

  • effects.zip
    831 bytes · Views: 13

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
@Quentin Moore
Ok, I got it... I was referring to a Private message through this site. Did you edit or create any effects .fx files? If you did, please send the .fx files also please. What might be occurring is that you may have edited or created an effects .fx file that is outside the limits of the effects.cfg file.
 
Messages
14
Country
southafrica
Doug,
There were a number of fx files created during my early attempts to install AFLT lighting in airports. I got confused around the issue of AFLT FSX and P3D lighting and was not choosing the P3D4 LOD compiler. A number of fx_AFLT_*.fx files ended up in my main Effects folder, but after I discovered my compilation mistake, all these files were deleted from the main Effects folder and in AFLT folders. I have had a number of fresh starts with AFLT and only the latest successful one remains active. The previous attempts were deleted before I made a fresh start. As far as I am aware, the only place where previous fx files exist is in the recycle bin.

Having searched extensively for fx files produced by the P3D4 LOD compiler without success, I can only conclude that they are either hidden, or the compiler produces a light effect which is non-fx in the bgl files it produces.

I have also been seeking help in the P3D Other Support Questions forum about this issue and the latest development from a number of tests is that there seems to be a problem with FS Dreamteam Add-on Manager, which also has a number of fx files in an Effects folder. We have just today determined that it's not the fx files which are a problem, but there seems to be something else in Add-on Manager which causes the error popup to appear. The involvement of Add-on Manager in this whole matter was discovered when I unticked its box in P3Dv4.5 Add-ons screen and found that the sim loaded without the error popup. I am waiting for P3D to tell me what to do next.
Perhaps you can throw some light on the latest developments (if you'll forgive the pun!)
 

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Hello @Quentin Moore
If you deactivated the Dreamteam's "Add-on Manager" and found no errors, the "Add-on Manager: is going beyond the limits set by the effects.cfg file.
What I suggest you do is uninstall the "Add-on Manager" and then reinstall it. What might have happened when you repaired P3D v4.5, it replaced the effects.cfg back to it's original form. So, uninstalling it and reinstalling should replace the effects.cfg file to what it needs to be.

I'm interested in what changed in the effects.cfg file.
 
Last edited:
Messages
14
Country
southafrica
Hello Doug. Your suggestion about uninstalling and reinstalling Addon Manager worked!! I am truly grateful.
I attach the previous and current effects.cfg files, for your perusal. I cannot see any change, so it seems to have been something else that was corrected.
Once again, my grateful thanks for sticking with me through this learning curve and getting the matter resolved.
Kind regards.
 

Attachments

  • effects.zip
    1.6 KB · Views: 8

Pyscen

Resource contributor
Messages
2,813
Country
us-texas
Hi...
Glad I could help!! I'm not seeing any difference either, but what might have changed was the .ini file (or settings) within the "Add-on Manager" (probably within your Documents folder where add-on information is usually placed). I suggest you check there.
 
Top