• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

ARGH! another run-time error

Sorry to bother you again with the run-time errors, as I know CAT is still in beta. :cat:

'run-time error "13" : TYPE Mismatch'


Error occurs after selecting ASM file and when I click on "NEXT".

Does this have any thing to do with American v/ European punctuation differences? eg . or , used as decimal.

Sorry my programming knowledge is severely lacking.
Hi Rellek,

No, it is probably something inside the ASM file I did not anticipate for and because of that CAT processes it wrong.

Can you please mail me the ASM files you used or post them on the forum? Then I can debug CAT (and hopefully we can have a non beta release soon :)).
Hi Arno,

Any news on this one?? I have just downloaded your latest CAT (0.91) and wanted to process my jetway animation. BANG! The same error as above...

Is it because it is a more complex animation? I mean, the object makes 2 rotational and 1 tranlational movement.

Could be, I never got the source file, so I have not debugged this specific problem.

But I have worked hard this weekend and v0.92 beta is almost ready. It contains a lot of improvements and each animation should work now. I hope to release it within a day or two.
Wow, super!

Yeah, I saw your development status post and I only could make out :greenflag 's

I'll wait for the new release then, and if the problem remains, I'll send you my source files.

Hi Jeff,

That sounds like a good idea.

Over the last weekend I have worked hard together with Nick to get CAT working correctly again. Until now we have not been able to break it yet with complex animations, so I hope that it will also solve your problems.

I while try to put the new beta online this evening.
Yes, you will like this... I will be the first to congratulate Arno on some very clever coding :)

The animations still have a very slight jumpiness... which we have so very nearly got rid of. If anyone can see in the source code the reason for this then let us know.

Another important note is that we found a limitation to the size of an MDL file. 1.35MB (or thereabouts) Arno will post more when the announcement and download is available.
The new version is now available for download.
Just watched Nick's video tutorial...hehe, I really enjoyed the Irish accent! :D
The vid watered my mouth, so I downloaded Arno's great work and tried to process a simple animation (a rotation of a box by 90 degrees).

All went ok until I reached the final step...clicked on "next" and again
Runtime Error 13, Type Mismatch...
I think it's something wrong with my setup here...VB runtime libraries and stuff...

I've attached my little animation code source files for you guys. I'm pretty sure it'll work on your rigs.

Last edited by a moderator:
Thanks, you found a bug :D. The problem was the underscore (_) in your filename, CAT did not anticipate for that yet. That has been fixed now. New version available for download.
Hmm, Arno, what are the limitations of CAT then? What filenames do You propose, what names of the objects do You propose so we can avoid the problems?
There are no limitations on the name. It is just that MakeMDL also uses underscores to combine the different elements of the name of label. I had thus to change the way these labels are read to collect the correct information from them, if underscores are also used in the name of the file.

I do not intend to restrict any limitations on the name, this sort of bugs should be ironed out before there is a v1.00, just like I now did with this problem.

The only limitation of CAT seems to be that the total MDL file of your object should not be larger than circa 1.3 MB. When Nick and I tested combining a lot of animation, using the secondairy condition, that was about the limit we hit. FS just crashes while loading with that very complex MDL. But I think this limit is only reached if you have a complex animation with a lot of frames and if you use a lot of secondairy conditions.
Hehe :wave:

It is actually an English accent. I was born in the UK, but moved to Ireland about 13 Years ago. Glad you like it!

Yes, the limitation that Arno speaks of, we found out pretty quickly, after trying to load a MDL that hit 14MB :)
No way!!! :D The underscore was the bad one!? hehehe
Yes, it works fine now. Finally, I can move on with my project!

Thanks, guys!

WOO HOO :rotfl:

CAT working fine on my machine now!

Sorry I did not post the source earlier but I became a new dad recently and have been very busy.

Congrats on another great tool.

Rel :wave: lek