• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Axis brake set commands problems.

Messages
1,067
Country
australia
The SDK says we can use AXIS_LEFT_BRAKE_SET and AXIS_RIGHT_BRAKE_SET to set brakes and gives the input and output values.

Only problem is AXIS_LEFT_BRAKE_SET appears to follow the values for AXIS_LEFT_BRAKE_LINEAR_SET which is not currently supported by the sim.

What this means is that if you set the left and right brake axis to, let's say, -8191 then the left brake will be set to 25% while the right brake will be set to 8%.

What to do in this situation? Either you account for the discrepancy in the two commands knowing it's possible that Asobo will fix the problem in the future (thus breaking your plane) or you just figure out another way of doing it.
 
I asked a question about this a couple of years ago, but did not receive an answer anywhere. I experimented with this for a long time. It turned out that the left axis variable sometimes even works normally, but most often it unstably underestimates the axis parameters. Thе solution to disabling and tracking via simconnect with an equalizing formula could not correct the balance, but at least it aligned both left and right axes to the same parameters.
 
Back
Top