• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Blender2MSFS support thread

Status
Not open for further replies.
Messages
218
Country
canada
There are a lot of different materials assigned to the bus and none of them appear to be setup correctly with MSFS materials. **EDIT Yes, there was one material that had an Albedo setup correctly, that's the material I renamed to MSFS.Bus2 just to be clean.

Attached an updated file with a single material with all faces assigned to it. Now, just select the textures in the MSFS Materials Params area.

** To check the faces with materials goto the materials tab with the object in "Edit Mode" and deselect all faces. Now, click a material and then click the button "Select" and it will show which faces are assigned to that material. There were multiple sets of faces in the bus that didn't have any MSFS materials. Hopefully this was a little part you were missing with the materials and mesh faces. Same goes for assigning faces to different materials, select only the faces you want for a specific material then click the "Assign" button. As long as the materials are MSFS and have proper textures you'll have a multi-material mesh. When the object is in "Object Mode", you can remove unnecessary materials from the mesh with "-" to keep it clean.
Thanks a lot!
 
Messages
46
Country
russia
Hello,
I have a problem with the terminal dome glass. We moving our projects from X-Plane to MSFS and get stuck with glass materials.
I'm using Blender 2.90 and MSFSToolkit 0.36.1.
I used settings from WildLynxPilot https://www.fsdeveloper.com/forum/threads/blender2msfs-support-thread.448402/post-856404 and gltf2 preview in Windows 10 looks as it should be, but in MSFS all windows are white and no transparent on both sides.
I played a lot with different parameters but result is always the same.
Can you direct me to any source or in best case give some step by step explanations how to make a glass? ;)
Original dome model and the texture file are attached. How to make it transparent, shiny and bit reflective for lights?
HELP! Please.
 

Attachments

  • glass.zip
    128.4 KB · Views: 48
Messages
466
Country
us-arizona
Hello,
I have a problem with the terminal dome glass. We moving our projects from X-Plane to MSFS and get stuck with glass materials.
I'm using Blender 2.90 and MSFSToolkit 0.36.1.
I used settings from WildLynxPilot https://www.fsdeveloper.com/forum/threads/blender2msfs-support-thread.448402/post-856404 and gltf2 preview in Windows 10 looks as it should be, but in MSFS all windows are white and no transparent on both sides.
I played a lot with different parameters but result is always the same.
Can you direct me to any source or in best case give some step by step explanations how to make a glass? ;)
Original dome model and the texture file are attached. How to make it transparent, shiny and bit reflective for lights?
HELP! Please.
Blender2MSFS Toolkit is now 0.40.0 and now compatible with 2.9.

In the .blend file, you didn't have the MSFS Material Params enabled. Included is an updated file with the settings used to get the following screenshots.
Glass_Test01.jpg Glass_Test02.jpg Glass_Test_blenderSettings1.jpg Glass_Test_blenderSettings2.jpg
 

Attachments

  • glass_Update.zip
    119.8 KB · Views: 69
Messages
46
Country
russia
Blender2MSFS Toolkit is now 0.40.0 and now compatible with 2.9.

In the .blend file, you didn't have the MSFS Material Params enabled. Included is an updated file with the settings used to get the following screenshots.
View attachment 62620 View attachment 62621 View attachment 62622 View attachment 62623

Thank you for example! Very useful!!!
My mistake was in the surface properties (under Use Nodes), which I tried to change to have effect on the glass.
Actually, there is nothing to change there. As you showed, we have to go directly to MSFS Material Params, select MSFS Glass and setup all our needs here.
I found that in the Texture maps only Emissive texture file will make glass as a real glass.
Here are my settings:
param.JPG
 
Messages
195
Country
us-california
Blender2MSFS Toolkit is now 0.40.0 and now compatible with 2.9.

In the .blend file, you didn't have the MSFS Material Params enabled. Included is an updated file with the settings used to get the following screenshots.
View attachment 62620 View attachment 62621 View attachment 62622 View attachment 62623
for some strange reason. i have blender 2.9 installed as well as 2.83. the older version of mstools installed fine with 2.83 but the new 4.0 tools will not enable in b2.9 or 2.9.1 i get thefollowing error...
 

Attachments

  • blrnder error.png
    blrnder error.png
    67.9 KB · Views: 45
Messages
466
Country
us-arizona
Never seen that before, how are you removing and installing the addon's?

Are you removing the older version via the "Remove" button in the msfs2blender addon dialog?
msfs2blender_dialog.jpg
After removing the older version I always restart Blender prior to installing the new one. Never have a problem using this method. GL.
 
Messages
195
Country
us-california
i did not have the older version installed in 2.9. i have the 3.6 version of tools installed in Blender 2.83. I downlaoded 2.9 and downloaded the updated 4.0 tools and went to install and that was what i got!
 
Messages
10
Country
canada
I am using 2.83 Blender, RenderDoc v1.9, Maps Models Importer v0.3.2 and Blender2MSFS toolkit 0.40.0. I am capturing a stadium from Google Maps. I import it into Blender , edit it and use A key to select entire scene, and then Ctrl J to join everything. I then set up everything to export the textures I hit Export extended giTF but nothing happens. The textures are not exporting at all. They should be in my PackageSources/modelLb/texture folder but there is nothing. So lost don't know what to do at this point. have tried different combinations of blender etc but same thing. Any help will be very appreciated!!!
 

Vitus

Resource contributor
Messages
1,480
Country
newzealand
@Av8rThor your error indeed looks like the one we got with previous versions of the toolkit. I'd recommend you clean up your installation and try that again. To do that:
1. open Blender, go to the preferences and uninstall the toolkit.
2. go to %APPDATA%\Blender Foundation\Blender\<version>\scripts\addons\ and make sure that there's no MSFSToolkit folder in there. If so, go ahead and delete it
3. Open you 2.9x Blender again, preferences-> addons and install the addon from the zip file again.

Keep us up to date if this worked! :wizard:


and then Ctrl J to join everything
I'm not quite sure why you'd want to do that? I never tried to use multi-materials on one object, I have no clue if the sim even supports that.

So why not leave everything as it is and just export the whole scene?
 
Messages
58
I am using 2.83 Blender, RenderDoc v1.9, Maps Models Importer v0.3.2 and Blender2MSFS toolkit 0.40.0. I am capturing a stadium from Google Maps. I import it into Blender , edit it and use A key to select entire scene, and then Ctrl J to join everything. I then set up everything to export the textures I hit Export extended giTF but nothing happens. The textures are not exporting at all. They should be in my PackageSources/modelLb/texture folder but there is nothing. So lost don't know what to do at this point. have tried different combinations of blender etc but same thing. Any help will be very appreciated!!!

are you putting ../texture/ in the texture box in the exporter.
 
Messages
58
@Av8rThor your error indeed looks like the one we got with previous versions of the toolkit. I'd recommend you clean up your installation and try that again. To do that:
1. open Blender, go to the preferences and uninstall the toolkit.
2. go to %APPDATA%\Blender Foundation\Blender\<version>\scripts\addons\ and make sure that there's no MSFSToolkit folder in there. If so, go ahead and delete it
3. Open you 2.9x Blender again, preferences-> addons and install the addon from the zip file again.

Keep us up to date if this worked! :wizard:



I'm not quite sure why you'd want to do that? I never tried to use multi-materials on one object, I have no clue if the sim even supports that.

So why not leave everything as it is and just export the whole scene?

When I was first learning by doing that same thing as the person above with Google Map import, it worked just fine joining and exporting, then after I learned how I baked everything into one texture and that worked fine too.
 
Messages
10
Country
canada
are you putting ../texture/ in the texture box in the exporter.

Yes I have ../texture/ in the export panel. It is so frustrating have tried many captures and imports into blender but same thing happens with the export. I am willing to spend the time to get it done, but gee what an adventure it has been and many many hours with no success. Hopefully someone can help me out.
 
Messages
10
Country
canada
When I was first learning by doing that same thing as the person above with Google Map import, it worked just fine joining and exporting, then after I learned how I baked everything into one texture and that worked fine too.



I'm not quite sure why you'd want to do that? I never tried to use multi-materials on one object, I have no clue if the sim even supports that.

So why not leave everything as it is and just export the whole scene?
[/QUOTE]

I did try that and same thing happens. Ctrl J is supported because I followed a YouTube video and that's what he did. The first time I tried it, it worked textures were created but I can not get it to work again.
 
Messages
58
DId anyone figure out why when creating multiple buildings (I am doing CYSJ, St John NewBrunswick) and I Have approx 15 buildings done that some show up right away and the rest only show up when I am close, it doesn't seem to matter how close I am when I start as some that show up are really close and others are far away.
 
Messages
17
Country
australia
I'm not quite sure why you'd want to do that? I never tried to use multi-materials on one object, I have no clue if the sim even supports that.

So why not leave everything as it is and just export the whole scene?

because not joining them as one object doesn't work. If you have multiple materials on multiple objects you MUST join all your objects into one object before exporting
 
Messages
58
Yes I have ../texture/ in the export panel. It is so frustrating have tried many captures and imports into blender but same thing happens with the export. I am willing to spend the time to get it done, but gee what an adventure it has been and many many hours with no success. Hopefully someone can help me out.

Are your textures Power of 2
 
Status
Not open for further replies.
Top