• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Export/Saving Model with MCX - Says "finished writing" But Never Creates File

Need a bit of help, I think I have MCX setup correctly (but obviously don't) as I am able to import a model and make edits. However, when I export it at an FSX.mdl, I get the "finished writing" message but the file is never created. Any thoughts on what I need to do here? TIA!
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Can you show your event log when you export? That should give a clue what is going on.
 
Does this help? I am simply attempting to remove the legacy splash effect.
 

Attachments

  • Splash Removal.txt
    2.1 KB · Views: 6
wondering if it is an issue missing the makemdle.exe file (which is confusing as I wouldn't think that would be necessary for exporting an imported FS .mdl file.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

It seems the X file is saved, but I don't see any output from the xtomdl compiler. Do you have the path to xtomdl set correctly in the options?
 
Thanks, but likely not correctly. I have ADE installed and am using the file there.
 

Attachments

  • Options.jpg
    Options.jpg
    573.3 KB · Views: 8
It appears I had to download the FSX SDK to get the correct modeldef file. I would say I'm surprised that I would need to do that but nothing surprises me anymore.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
If you want to export a FSX MDL file, you need of course an SDK that matches that version. Since the FSX SDK can't be downloaded, that would be the P3D 1.4 SDK.

Which XtoMDL version did you use before then? It is weird there was no output at all.
 
If you want to export a FSX MDL file, you need of course an SDK that matches that version. Since the FSX SDK can't be downloaded, that would be the P3D 1.4 SDK.

Which XtoMDL version did you use before then? It is weird there was no output at all.
I actually found a version of the original FSX SDK but previously was using the XtoMDL that was with ADE.
 
Top