• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Fast moving animations jittery looking

Messages
195
Country
us-texas
I am using Blender 2.9.3 and the old original MSFS Exporter. Slower walking or posing animations play fine, but whenever I need something to move a larger distance in a shorter period of time (like a deer running), then I have to try to adjust the FPS in Blender. I have tried all of the Blender FPS Anim adjustments that I know of (Time Remapping, Frame Rate, manually squeezing or adding frames, etc...), and the effect works in Blender but not in MSFS. Hence, MSFS seems to have locked the animation to a lower FPS no matter what. This seems to have very little effect in MSFS, almost like it's capped.

Also, some of my animations disappear from certain angles (just like what happens with Asobo's walking marshallers), maybe related to LODs though as I haven't experimented with multi-lod'd animation. The farther away from the animated object, the more jittery it looks.

Anyone know anything that helps, maybe using Sim Object instead of regular object for animation?
 
Top