• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2002 Gamepack and CAT

Ok decided to use the FS2002 gamepack, so I can make a conditional animation. Reinstalled Gmax and copied the makemdl file into the Gmax plugins folder. Opened my Gmax file and tried to export, but could not select anything that has to do with FS. Why doesn't it work? :banghead:

[edit] Just read that you need some other files aswell, but since I don't have FS2002 pro, I do'n't have that files too. What to do now?

Last edited:
I think you can take those files from the Fs2004 gamepack. If you look in the Fs2004 gamepack you will see there is also a document there describing how to use both together.
I get an export module failure. I think the problem is in the FSModelExp.dle I don't have a FS2002 version of that file. I tried to use the FS2004 version but it doesn't seems compatible. Can you mail me the file (jorritvandommelen@hotmail.com) Thanks.
When everything works, do I have to choose the version?
No, as described in the documentation you need to use two different links to start GMax. One for the Fs2002 gamepack and one for the Fs2004.
Arno, I've installed your gamepack, but when I load Gmax via the link in the Fs2002 folder I get the following mesage:

Class <FSModelExp> from <FSModelExp.dle> has duplicate class ID: not loading. This may be due to duplicate plugin path.

Continue showing this warning for other duplicates?

[yes] [no]

If I click yes the same warning shows again and after another yes Gmax starts.
When I export my model, via file - export the FS2004 makemdl loads again. :confused:

Not how it should be, I think

Just wondering: There is a button "compile bgl" Will that function be included in the next release?
Last edited:
Hi Jorrit,

Check if there is not a FsModelExp.dle in the general plugins folder of GMax. They should only be in the gamepacks\name\plugin folder.

At this moment we don't know what will work in the next version, but usually something has a backwards compatibility of 2 versions, so I guess these BGLs of Fs2002 should be fine.
Hi Arno,

Checked and that was the problem.
Now I've arrived at the next problem :banghead: When trying to export a model, the FS2002 makemdl loads. But I get a message that makemdl isn't found or makemdl has failed to export my model. I'm now very sure that everything is installed correct. I reinstalled Gmax, in the same map as you (c:\flightsim\gmax), so I didn't have to change things in the files. Copied your gamepack into gmax, but the problem still occurs. :( :mad:
Why do I have al those problems in everything I try? :banghead: :banghead: I can't really say that I enjoy making scenery at the moment :(
Are you sure your windows regional settings are set to dot (.) instead of comma (,). MakeMDL does not work with the common Dutch settings. That is a common reason for this error.
It worked with the FS2004 gamepack. I changed the settings from , to . but I still get the same error. So it is another problem.

(This week I'm not able to reply)
Last edited: