• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 Ground illumination missing

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
You're up rather late!

Figured it out, Adjacent lights should have different Layer numbers specified.

Almost "there"
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
I have just posted Development Release 4.5.1.8(a). It resolves (at least on my system with limited testing) all the issues noted above except use with PV5. PV5 requires a different compiler for the GPs, which will take to time to port from ADE-GP. As well, since GPs in general don't work with PV5 if use is made of sloping runways, I need to consider whether porting is even worthwhile.

Please give this new version a try and report remaining issues - making note of the "corrective" comments throughout this thread regarding layering (and now reflected in the updated user manual.)
 
Messages
1,413
Country
germany
Hi Don,
my first test look rather fine:
- all heads are now okay ( only the 5-head-ramplight has the heads on the opposite side of the ground illuminations )
- the ramplights have ground illumination without flickering
but the other Light Standards have no ground illumination.

Light4.jpg


Light5.jpg


Please tell me, which files do you need.

Thanks and best regards
Guenther
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Did you install the whole release or just the .exe? The whole release is necessary.

Did you adjust the layer #s of each standard. If not, you must to seer the illuminations in the back row.

As usual, I need your Project Folder to diagnose issues, (but only after you've made the noted adjustments and retested)
 
Messages
1,413
Country
germany
Thanks,
I used a new folder for this release and copied my "Project" folder into it.

I did not adjust the layer #s, sorry, my fault.

I will test it tomorrow, today I am very tired from rowing my fishing boat 19 kilometers on Lake Ammersee without any strike.

:rolleyes::)

The opposite ground illuminations of 5-head ramplight can be solved by changed directions in standard.txt:
Ramp_5-Head_Striped |Ramp_5-Head_Striped | illum_Flood | 180 | M | -1.5/-1/-0.5/240/70/25/25; -0.75/-1/-0.5/210/70/25/25; 0/-1/-0.5/180/70/25/25; 0.75/-1/-0.5/150/70/25/25; 1.5/-1/-0.5/120/70/25/25
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
The reason I suspected you had not installed the whole archive is that the 5-head standard is still 180 from its illumination, a issue I discovered during testing yesterday and fixed by updating the model in the BaseModels folder.

All models display correctly and all have associated illumination (on my system) in the attached file (layers adjusted) which you can copy into your Projects Folder and compile. (The Walkway_Globe model is no longer available- and should never have been; it's the Globe for Walkway_Fancy in a standalone mode.)
 

Attachments

  • Placements.zip
    6.7 KB · Views: 51
Messages
1,413
Country
germany
Thanks Don,
your placement.xml works fine for my test airport VOHY.

I added a "Light Standard Street" and it worked after I changed the GP Layer number.
It looks like I have understood. :)

Light6.jpg


For a very large airport like ZBAD the GP Layer thing could be more work than placing Ramplights in ADE, I suppose.

ZBAD1.jpg


I realised another problem:
If I edit a light, (like the declination) on the screen and copy and paste it, the copied light has the default declination, not the changed declination.
To solve the changed declination it is necessary to save placement data before copying the light.

A last comment, the alpha channels of the other lights could be smoother (like illum_Flood.bmp).

Anyway, thanks a lot!
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
For a very large airport like ZBAD the GP Layer thing could be more work than placing Ramplights in ADE, I suppose.
AFLT isn't in competition with any other ramp-lighting application. It's an alternative that offers some unique features.

If I edit a light, (like the declination) on the screen and copy and paste it, the copied light has the default declination, not the changed declination.
I didn't have any such difficulty. I created a new standard with stock parameters, Then, I changed the declination, closed the edit dialog, right-clicked on the edited light, selected copy and then paste. Opening the edit dialog for the pasted standard which had the revised declination. No saves of placement data involved.

A last comment, the alpha channels of the other lights could be smoother (like illum_Flood.bmp).
You could try converting the various illum_ . . . textures to 32-bit format as you initially did for illum_Flood for FS9. All other versions use DXT-5 compression which seems adequate. I will convert the FS9 stock textures to 32-bit format before the next general release.

EDIT: FS9 illum textures are all already in 32-bit format. This is as good as it gets for FS9.

It would seem AFLT is now working as intended for FS9.
 
Last edited:
Top