• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS [GUIDE] How to create custom aerial scenery

Messages
4
Country
us-ohio
Hello,
So I've been working on two airports and I wanted to get some better orthophotos in game for reference for building the airports. The first airport I did, I68, worked fine, but the second airport I tried to do it for, KMWO, it doesn't show up. I see that sometimes photogrammetry can obscure the orthophotos but this area has no photogrammetry. I tried turning it off anyway, and it didn't help. I know I'm following the steps correctly because it worked at the first airport I tried. I even redid it multiple times to make sure I wasn't doing anything wrong. Does anyone know what could be going on, what I could try?

Edit: I did this for another airfield, 19i, and it worked fine, but another airfield, KISZ, won't work. Why?

Edit 2: I think I see a pattern. All of the times it has worked, the package folder contains one .cgl, named "sai001.cgl". Every time it doesn't work, the package folder contains two .cgl, named "sai000.cgl" and "sai001.cgl", of which the former is the larger one. Maybe if I could combine the .cgl into one it would show up?

Edit 3: So I tried deleting all the empty .png from the aerialimages folder before building the project, and after building it, it now is only generating one .cgl file. And, best of all, it works in game!
 
Last edited:
Messages
10
Country
unitedstates
Hi all,
Having a little trouble with my aerial. I did the steps for the custom aerial and that part was fine. However, I have to turn photogrammetry off to see it. Is there a way to have photogrammetry on and still have my custom aerial show?

I am having the same problem. Did you ever figure it out?
 
Messages
7
Country
australia
Hi all, I got to the end of the document without too much trouble. I know Augustine strongly recommends only attempting this as a seasoned scenery developer, but being the irresponsible brash old bugger I am, I decided to press ahead anyway, and have a couple of questions regarding the 'compiling' section of the guide:

1. The guide says the asset directory should be set to PackageSources\CGL. It says the output directory should be CGL\ ... Does that mean both directories are the same?
2. Is there a way to have the console text remain? It appears for a few seconds then disappears.
3. After what I assume is completion (the console text doesn't hang around long enough to confirm it's finished), I have a 'Packages' directory created, but there's only layout.json and manifest.json in there, with nothing else. I assume that's incorrect?

Thanks very much Augustine for the guide, and y'all for any help ;)

Cheers,
Bucky
 
Messages
137
Country
poland
1. The guide says the asset directory should be set to PackageSources\CGL. It says the output directory should be CGL\ ... Does that mean both directories are the same?

No. The second one will go the your output folder. Likely called "Packages" alongside the "PackageSources" folder unless you have changed that somewhere in your configs.
That output folder will also be the one that goes into your community folder.

2. Is there a way to have the console text remain? It appears for a few seconds then disappears.

Yes, just call it from an open CMD window or create a BAT file as follows alongside your project XML:

Code:
"<Your MSFS SDK Directory>\Tools\bin\fspackagetool.exe" YourProject.xml
pause
 
Messages
7
Country
australia
Thanks @Sasa! I'll give the windows console trick a try! Appreciate the responses, and thanks very much for the help!
 
Messages
7
Country
australia
Thanks to your tip, I was able to see the console errors, however, after much fiddling to try and figure out what's wrong, I'm not really any closer. I have an aerial-imagery.xml located in PackageDefinitions and it looks fine. I'm not sure if that's what it's referring to?

1641077135172.png
 
Messages
137
Country
poland
Download the SDK samples and check out the Simple Aerial sample.
I assume it's the CGLBuilderConfig.xml this error is referring to. It's a simple file describing the location to the source files (not exactly sure why this extra jump to the source files is required but it is...)
 

Md Alavi

Resource contributor
Messages
172
Country
bangladesh
anyone knows why the tiles2bing not converting files? I had geo referenced the imagery through QGIS.


1654001898951.png

1654001918001.png
 
Messages
5
Hello everyone
Is there any way to rename CGL file and it's folder to make it visible in sim? I am trying to make a new island aerial imagery (1.3 gb CGL file) ZL19 and besides some strange errors in console all looked fine for me at the build stage (tho it taken 30-40 minutes to build) and the package was fine for me. But I saw mentioning here that similar names for CGL files make community ones not to load.

For me the folder name is already taken by Asobo CGL's but not the CGL name (which is sai333.cgl) and changing folder name and folder path in layout.json of exported package didn't help.

I followed the Guide provided above, except Othro4xp part - made initial aerial PNG image myself


Also I found this mention in the docs.flightsimulator:
"All image files for aerial images should be authored as 16bit PNG with a fixed size of 256x256px, and the build process will automatically generate the images for the lower levels of detail. "
I can see that .png tiles created for sim with this guide have a 32 bit depth. Can this be a problem?
 
Last edited:
Messages
2
Country
flag
Attention, is this worrying?

Ortho4XP readme states:

Download the following packages from https://www.lfd.uci.edu/~gohlke/pythonlibs/

Pyproj, Numpy, Gdal, Shapely, Rtree, Pillow (or alternatively Pillow-SIMD)

Website is closing:

Unofficial Windows Binaries for Python Extension Packages

by Christoph Gohlke, Laboratory for Fluorescence Dynamics, University of California, Irvine.

Updated on 24 June 2022 at 07:27 UTC.

Funding for the Laboratory for Fluorescence Dynamics has ceased. This service will be discontinued before July 2022.
 
Messages
5
I am trying to figure out why is my CGL don't show in simulator. This is the console log after package build is completed, looks ok for me. But maybe there is some bad errors you can see here?:

Capture.JPG
 
Messages
35
Country
us-northcarolina
For time saving I recommend using Sbuilder515 to generate a single image file containing the whole airport.
Here is the process I used and didn't need to spend as much on GIMP
1- Open Sbuilder ignore the paths warning for FSX and its sdk tools by clicking OK. Just ignore everything until you get to the main screen.
2- Click on View show Background and navigate to your desired location. To move faster you may need to go to Edit > Tile Servers and choose Google_api3_Basic Map until you get your desire position then revert back to google satellite server (Google_api3_Satellite)
3- Navigate to your airport location then zoom enough to show everything you want to capture
4- Go to File > Add Map > From Background
5 -Choose the zoom level you want. Left Click on top left and drag to the bottom right to encompass the area you want with a red rectangle. Then you wilI see Number of Tiles and size to the right. I would recommend something with less than 1000 tiles as the size can be very large, so may need to make several captures. My computer can handle about a 1000.
5 - Click OK and it will process the tiles, it may crash or get stuck. I'll show you how to handle that.
6 - It will show a notification box that says xxx tiles are being downloaded at this moment. Please repeat this operation when downloading is complete! Click OK. Then Click OK again. If Everything is good it will have generated a .BMP image file and a .TXT text files with coordinates for it in the following folder: SBX315\Tools\Work
7 - You can now open this single image in GIMP and add a selection using the Free Select Tool for instance or Fuzzy Select tool around the area you want to keep, invert the selection (CTRL + I) then go to Layer > Transparency > Color to Alpha
Make sure you have the image into a new layer and that you can see only see the area you want everything else having been erased.
8 - Export your image (Shift+Ctrl+E) as a PNG and continue the rest of the tutorial.
Where can I download the Sbuilder515? I have 315, but cannot find 515. Disregard, I did not look far enough. Thank you
 
Top