• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

help- Gmax Setup with Prepar3d SDK V1.4

Hi all,

could somebody kindly help me out with setting up Gmax to correctly interface with P3d SDK 1.4? Sorry to say I'm a total beginner to modelling software.
I own the FSX :SE which unfortunately comes with the incomplete SDK. I searched on the internet and found that the best option for steam users is to use
the P3D SDK v1.4 which I downloaded and installed.

The "READ FIRST: FSX SDK installation (all versions)"thread on here , unfortunately leads to a "bad title" and --The requested page title contains invalid characters: "%28" message--.
for me , when I click on the blue "SDK installation FSX" link. I tried with two browsers, same result. Could somebody point me to correct page?

I found the original reddit forum post about setting Gmax up with the P3d V1.4 SDK, but I'm stuck at the point where you set up the path reference for the modeldef.dll.
The reddit guide simply says:
"Open gmax go to customize – configure path add and paste the way to the modeldef.dll. Now it should work."

However when I go to customize->configure path there are four tabs, I'm not sure within in which to add the path to modeldef.dll.
Do I need to add anything else ?

I read the P3d SDK documentation on the environment kit but I had trouble understanding how to make it work, as among other things it bluntly states as a first step:
install 3dsMAX7 7+.

Sorry if my questions are sounding dumb to you experts, but I'm really starting more or less from scratch with zero SDK usage knowledge and english is not my native language,
so I kindly ask for some patience.

Kind regards,


P.S:: I forgot to say, not sure how to proceed generally regarding the various SDK components. For now my aim was simply to take a first step towards modelling
an aircraft in the FSX native format, so other things like scenery design I do not intend to use right now.

Here is the ADE report, I suspect a lot of stuff is set up wrong or missing. Sorry.:

Date of Report: 17.03.2018 10:49:23
Operating System: Microsoft Windows
OS Service Pack: n/a
OS Version: 6.2.9200 (64 Bit)
OS Language: Deutsch (Deutschland) => separator: '.'
Nodename: PC
ADE installed: no
ADE Path: D:\MSFS\FS Design Tools\Ai (manually set)
ADE Install Version: n/a
ADE File Version: 1.75.6421.26577
ADE Info: n/a
FXS installed: yes
FSX Path: C:\FSX\steamapps\common\FSX\
FSX Version: 10.0.62615.0 (FSX.20150710-1055)
FSX Trailing '\' Error: Falsch
FX9 installed: yes
FS9 Path: C:\simulator4\Microsoft Games\Flight Simulator 9\
FS9 Version: 9.01.040901.01
FS9 Trailing '\' Error: Falsch
RTM Simconnect: yes
SP1 Simconnect: yes
SP2 Simconnect: yes
FSX SDK installed: no
FSX SDK Path: n/a
FSX SDK Trailing '\' Error: Falsch
BGLComp Version: n/a
BGLComp >= SP1: no
Shp2Vec found: no
.NET 1.1 installed: no
.NET 2.0 installed: yes
.NET 3.0 installed: yes
.NET 3.5 installed: yes
XML3 installed: yes
XML4 installed: yes
XML5 installed: no
XML6 installed: yes
FSUIPC/FS9 installed: 3.999z8
FSUIPC/FSX installed: 4.966c
Connected to FS9 ok: no
Connected to FSX ok: no

Last edited: