• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS MSFS Asobo Official Blender exporter

Update on the above.....simply under the Data option in Include.....UNCHECK "Custom Properties".....works like a charm!
 
I have "custom properties" deselcted, see if that helps you.

1680560513479.png


I think I didn't even use the File / Export / glTF menu last time, I believe for my latest project I did it through the Multi-Export tab from the start. I'm pretty sure this and the Objects options below are all you need?

1680560648273.png


And if all else fails, I'm using Blender 3.3.3 and version 1.3.0 of the MSFS exporter, I can guarantee it works with those versions. To be sure, when you create a material ONLY set the MSFS properties, although using an MSFS "Standard" material and applying a Blender Subsurface color to tweak it works fine.
 
Last edited:
Hello everyone, my first project started in Blender 2.8, now Blender 3.3 and Asobo Exporter current version 1.3. The following error occurs with an untextured object only with Blender standard material assignment. I used to use the old exporter that wasn't from Asobo I got gtlf and got files, now I don't. Can anyone help?

Screenshot 2023-06-30 181937.png
 
ASOBO just released exporter 1.3.1 Use that.

Can you reproduce this using just a cube and export?
Do you have the core gltf export turned on?
Can you post your blend file - (or parts that don't work)?
 
ASOBO just released exporter 1.3.1 Use that.

Can you reproduce this using just a cube and export?
Do you have the core gltf export turned on?
Can you post your blend file - (or parts that don't work)?
First of all, thanks for the answer.

With a cube and version 1.3.1 the same problem. Is there a complete documentation/manual for the exporter?

The fault will be mine because I'm probably doing something wrong
 
First of all, thanks for the answer.

With a cube and version 1.3.1 the same problem. Is there a complete documentation/manual for the exporter?

The fault will be mine because I'm probably doing something wrong
The documentation is in the plugin zip and on the GitHub

Try with a portable version of blender like this one, unzip


Copy the io_scene_gltf2_msfs folder from the plugin zip to the

Unzipped folder\scripts\addons

Run blender and enable the msfs addon


Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
Zip up the cube .blend you made and attach it to a post. Then we can see if the exporter is not working.
 
Ensure you have both gltf addons enabled. There is a core Khronos default blender gltf addon , plus the ASOBO MSFS gltf exporter addon.
DA40_CGDFQ_2023.07.02_11h6m3s.png



Also the first time you export the default gltf export type will be glb - change that to gltf Separate



DA40_CGDFQ_2023.07.02_11h7m5s.png
 
Update:
It doesn't work with the other Blender version either.

Default GtlF is disabled in Blender.

The Asobo Exporter also shows version 1.3.0 when downloading version 1.3.1. Removing and reinstalling does not change anything.

The manual on Github is very limited (there is no manual in the zip file), i was now able to check all settings with the manual and couldn't find any error.

Enclosed is the zip file of the cube.

Thank you very much for your help
 

Attachments

  • CubeTest.zip
    109.9 KB · Views: 88
I get a valid gltf with this:
Untitled.png


Untitled01.png


The destination of "//" puts it in the same folder as the .blend file
 
The zip file containing the addon has not been properly set up to be installed by way of Blender. You will need to unzip and temporarily place it somewhere and then within the addon folder... do one or the other..

You can either copy and paste the unzipped folder or install through Blender the nested zip file.
 
Last edited:
@rhumbaflappy
So it's because of what @Pyscen wrote? The addon in Blender is not installed correctly?

@Pyscen
I don't quite understand that, it may be because I know very little English and translated it. Maybe it's because of the translation.
I can only install the addon in blender as a zip file? Why should I unzip them? The zip file is stored in the Blender addon folder and installed from there, no change, still the error
 
As @Pyscen said, and as suggested before

Unzip the zip in a temp folder,

You can follow the video instructions here, was for the previous exporter, but install process is the same


Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
You need to unzip the file because the addon wasn't zipped correctly to install the addon.within Blender.

1st unzip.the file. Then, within the 'addon' folder you will see a folder and another zip file. This zip file, you will want to install using Blender. After you install this zip file, you will need to activate it
 
So now I understand what it's all about. I did the installation exactly according to the video instructions (source code download, io_scene*** folder copy in Blender/3.3/Script/Addons) and it's the same problem, but now version 1.3.1 is displayed correctly in Blender. There is an update on Github which removes the faulty zip, re-downloaded it and installs the zip as usual, also the same error. The Exporter export only a .xml file and forget the .gltf and .bin

standard glTF from Blender works. And yes, I deactivated it again before I tried it with the Asobo exporter ;-)

I'm starting to feel really stupid, I'm sorry. with the old exporter (the one before the official Asobo) and Blender 2.8 everything worked. I don't understand the world anymore
 
I just tested the whole thing on another PC where Blender was never installed. Blender 3.3 in the automatic installation in the default directory. Exporter ZIP file loaded, copied to the addon folder and the same error when exporting. Now I have to find out which file it is exactly that he says he can't find
 
This should be a very easy install process.

It should be:
1. download the io_scene_gltf2_msfs.zip
2. open blender
3. Menu - Edit - Preferences
4. click on install... button
5. navigate to the zip file you downloaded in step 1.
6. select it - click on Install Addon
7. check the checkbox to enable the newly installed addon.

It is explained on the git site readme - How to install the addon

EDIT: Oh and ASOBO did make an error on the zip - they uploaded ver1.3.0 as the io_scene_gltf2_msfs.zip in the 1.3.1 release, however the io_scene_gltf2_msfs.zip inside the source_code.zip was correct. I think this was changed (fixed) on Wednesday July 5th
 
Last edited:
Back
Top