• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS MSFS Asobo Official Blender exporter

Why am I getting this..Thanks for any help
also where is this? You need to uncheck the "Use Asbob_unique_id_Extension"
Is this a file that worked for you previously but fails under 3.3?

Here's an example with that option checked, it exported OK actually with Blender 3.3 and the latest exporter.

1674678454764.png
 
I downloaded 3.4.2 I believe and you can't import the zip for glTF-Blender-IO-MSFS-main (zip) It will install MSFS Toolkit but not the other. Also in both programs.. the xml is messed up and you have to edit every one of them?

Thanks

BobM.
 

Attachments

  • what the default xml looks like.JPG
    what the default xml looks like.JPG
    67.5 KB · Views: 70
As far as 3.3..do I need both MSFS Toolkit and glTF-Blender-IO-MSFS-main (zip) Which one is better in your opinion

Thanks,
BobM.
 
As far as I know Blender2MSFS Toolkit is not being actively developed anymore, while glTF-Blender-IO-MSFS-main is supported by Asobo with a recent LTS version of Blender, so I would think that's the only one you need.
 
All,

The latest ASOBO exporter ver 1.3.0 (ASOBO ver =1, Blender minor version = 3, ASOBO exporter patch =0) will work with Blender 3.1, 3.2 and 3.3.
It will NOT work with Blender 3.4 or 3.6, as there is a Blender breaking change in renaming the MixRGB Shader node.

You should remove any legacy Vitus exporter as it is no longer being actively updated. And it will interfere with the ASOBO one.
You should use the Edit Preferences menu in blender and select the add-ons button and search for msfs. If you find it then open it, using the triangle to the left of the name. Click on the remove button.
DA40CGDFQ_2023.01.27_10h20m14s_33.png


You may want to ensure that the legacy Exporter add-on is totally removed by checking the Blender files in AppData folder and also the scripts/addon folder in the Program Files - but this is not necessary.

Once the legacy exporter is removed, then close blender and reopen Blender.

Check that you have not inadvertently deleted or disabled the core Khronos gltf code (version number is dependent on what version of Blender you have) - This is is required for the ASOBO exporter to work. You should see the "Import Export: glTF 2.0 format" add-on. (search for gltf)

DA40CGDFQ_2023.01.27_10h33m06s_35.png

My suggestion is to follow the install procedure outlined in the latest Readme (git repo from Jan 27, 2023), that is to use to Edit Preferences Install Tab and the zip file named io_scene_gltf2_msfs.zip.
DO NOT USE the git download of the entire main branch, as this has the wrong folder structure for the Blender install. Use the release download, not the main branch download.

DA40CGDFQ_2023.01.27_10h27m53s_34.png

Follow the instructions on the latest readme for the preferred method to remove/install the ASOBO exporter.
EDIT: also Blender 3.3 needs you to set the animations export optimize checkbox, in order that animation names are not duplicated error is suppressed.
DA40CGDFQ_2023.01.27_10h46m19s_36.png
 
Last edited:
Now for the bad news. It seems there is a Blender/Khronos/ASOBO issue, where you can have long export times with the ASOBO exporter.
This has been reporter to Khronos, Blender groups, and ASOBO is aware of it. This may result in export time increasing by a factor of 10-100 - an export that took 40 seconds in 3.1 will take 10-20 minutes in 3.3
My suggestion is if you started a project in 3.1 and lower - remain there. Only start new projects in 3.3.

If you find a workaround for this please post here and on the ASOBO git issue.

Blender 3.3 has a better bone/armature animation features, so you may want to use Blender 3.3. Users have tried moving/updating their models by using File Append in blender, or rebuilding ALL the animation (a huge task), but this may or may not help export times.
 
Strange.. I show it listed in preferences/addon but its not showing in the export options? I have 3.3 Sorry for the large eyeball lol
1674849450906.png
 

Attachments

  • addon1.JPG
    addon1.JPG
    65.4 KB · Views: 88
  • Addon2.JPG
    Addon2.JPG
    27.5 KB · Views: 81
For this exporter you expand that side menu (little < arrow to the right of the Gizmo Y axis) and configure all your options and export there.
 
The ASOBO exporter is part of the built in gltf export. Just export using gltf 2.0 and you will get the options for exporting MSFS objects.
 
Strange.. I show it listed in preferences/addon but its not showing in the export options? I have 3.3 Sorry for the large eyeball lol
View attachment 86158
You deleted the built in core glTF exporter or it is not enabled. Please reinstall Blender if you deleted it.

edit: your addon2 picture has two folder for the msfs exporter, delete the glTF-Blender-IO-MSFS-main folder. Only install the io_scene_gltf2_msfs.zip from the release section of the ASOBO git site. Not the main branch.
 
Last edited:
Thanks @ronh I got it fixed. I reinstalled Blender and got the right part of the main zip installed.
Have a great day!!

BobM.
 
Things to check.

1. If your project was started in Blender 3.2 or lower, go back to 3.2 or lower.
2. Try exporting without the Include - Selected Objects checkbox selected. (You still have to select you nodes - ie. press the A key (select all))
3. Ensure all your materials have been "Migrated" - there is no Migrate button sitting above your MSFS Material Properties panel when you view the material.
4. Isolate your animations - ie. hide all your nodes with animations, then unhide them one at a time - export - to find the "bad" animation and rebuild that animation (this may of may not fix things)

DA40CGDFQ_2023.01.28_16h53m04s_37.png
 
Last edited:
what does this mean?

Thanks
BobM.
BobM, have you tried the workaround I mentioned above, where you start a new Blender file, Append your Collection from the original file that gives you the error, set the exporter settings again for the collection and try to export again? I fixed similar errors this way while moving from 3.1 to 3.3 with the latest exporter.
 
Back
Top