• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Newbie question regarding Blender 3.6.0

Hi all

I have downloaded the latest version of blender to have a go at simple object creation for fsx se. I have downloaded the tool set I assume is for the latest version and gone to preference, install and navigated to the folder Blender2P3DFSV.
Clicking on file and looking at the export option I can't find the option to export to MDL or BGL.
In the "enabled addons only" I can't find a reference to mdl or bgl
Can anyone point me in the right direction on what I have missed



If you have downloaded version 1.03 of the toolset from the Resources forum that is the latest version of it. It is for all Blender 3.x versions.

I suggest that you have a look at the wiki for the toolset.

You should see this under File->Export in Blender:

Also, be aware that the toolset maybe installed but you will need to activate it also. The wiki, forementioned, has details on how this is done. You can determine if it is installed and activated by prssing the N key within the viewport in Blender

You must install the P3D SDK v1.4 iprior to installing and activating the toolset. The SDK Isn't complete for FSX: Steam. You must use the P3D SDK v1.4 version. It is also available within the Resource section.
Last edited:

Thank you for that. I clicked on addon install but nothing has installed in the script addon folder I have the sdk installed as I use object placement


Edit: Are you installing the zip file? That is the easiest way. Do not extract the toolset from the zip file.
You mentioned that you are a noob, maybe this page from the Blender manual about addons will help.

When you click install (1) to install the zip file, do you not eventually have this (2) appear in your Add-ons list?


Actually, after clicking the zip file to install, that number 2 line should appear by itself when you move the mouse over the area. Just click the checkbox.

Are you referring to the script addon folder at: Users/your user name/AppData/Roaming/Blender Foundation/Blender/3.6/scripts/addons?
Last edited:
Hi Dave

I think user error on my part. I need to open the folder and click on the individual files to install them.

I need to open the folder and click on the individual files to install them.
Hi Rhys,

I'm afraid I don't understand what you mean.

You're not trying to install this in the Program Files Blender Foundation, etc., etc., addons folder, are you? Blender wants to put third party addons that are not part of the Blender installation files in the folder mentioned in reply #5 above.

I don't know if you have downloaded any other third party addons yet. What I do is create a folder for them. That is the folder I refer to in the following sentence.

When you click on Install from the Blender User Preferences as shown above and go to a folder you keep your zipped addons in, select Blender2P3DFSX v1.0.3.zip, then click the Install Add-on button, does that not install the toolset?


There isn't any reason why you should have to install any individual files.

That is the easiest way to install any third party addon, because Blender does the work for you of putting the addon where it wants it, creating any needed folders, etc.

The other option for this toolset is to extract the files, and copy the Blender2P3DFSX folder that is inside the extracted zip, intact, to the addon folder in the path mentioned in reply #5. If you haven't installed any other third party addons, you will need to create the last 2 or 3 folders in that path and then paste the Blender2P3DFSX folder in the addons folder you created. Then when you open Blender, and look at the User Preferences, you might have to click the checkbox to activate the toolset.
Last edited:
Hi Dave

Thank you for that . I am so used to removing folders from zip folders that after re reading your post and placing the zip file in a new location, I was able to install the addon-on and the export mdl know appears

Cheers very much


Since you are new to Blender, I suggest rather than starting in on something you want to make, just do some things with the default cube.

Like maybe changing the shape of it, or make a very simple house shape from it. Then try UV unwrapping it and texturing it.

Try to export it. You can always look at the .mdl in MCX.

It can take quite a while to learn to use Blender.

If you do some simple things to get familiar with it, you might save a lot of frustration from having to remake something you care about due to really messing something up with it.

There are many beginner tutorials on YouTube, as well as for different modeling techniques.

An Internet search for some problem will usually have at least one result on blender stackexchange where there are answers for almost "everything."

Good luck!
Hi Dave

Having a play with blender and following some basic tutorials. I played with the cube and went to export to .mdl but got a window come up with error message




  • error.jpg
    89.8 KB · Views: 50
The file mentioned is a part of the SDK. What SDK is installed? The P3D SDK v1.4 should be used with Steam only.

Please show steps taken.
Hi Doug

Thank you for the reply. I have blender on a second computer and using that for modeling. While the second PC does not have fsx se installed I do have the sdk in the
(86x) program folder. I had a try at re exporting the cube this time I navigated to the / Lockheed martin folder-Prepar3D SDK 1.4.4747.0 -Environment Ki t-Modeling sdk -3DSM7 folder where the modeldef.xml is and got this error message
error 2.jpg

Is there a link to download the 1.4 SDK here in fs developer?. I can't find the original one I had downloaded on my PC



You shouldn't need to point to the file named above. Since you have installed the SDK in the default location, all that you need to do is set Blender accordingly:

Screenshot 2023-07-08 201818.png

Make sure "Auto Detect SDK" is checked. Make sure to "initialize" the SDK before attempting to convert. Make sure to fill in the friendly name" and Generate a GUID. before attempting anything.

You must "Initialize the SDK" before you do anything. (including loading up your model). Watch for any errors. Then, you must have a "friendly name" and a GUID before attempting to convert. .
Thanks Doug

Where can I find the the options menu as shown in your above post, looked in the preference menu but cant find it


Hi Doug

Thanks for all your help on this but but still no luck, still getting an error message and the only file a have a created is a .X file I only want to create two simple objects. One is a log 6 meters long and 250mm in diameter and a pipe 7 meters long and a diameter of 500 mm and 2 cm thick. My helicopter sim is set up for sling loads so the objects have to be exported to MDL files so they can be lift able



I'm not sure about this, but if you're still getting the permission error that is at the bottom of the image you posted above, I suggest that you install the SDK in another folder.

I don't have FSXse, but this is what I've got on my computer. Neither FSX nor it's SDK are in the Program Files (x86) folder. I've never had any folder access permission problems:

It shouldn't matter if the SDK for P3D v1.4 is installed in it's default or other location. The P3D SDK is different from the original FSX SDK - The P3D SDK when installed gives permissions (OS has changed since the original FSX.)


Do the 2 objects within the same blend file or are they 2 separate blend files? Also, do both of these objects have a "material" assigned to them and/ or textures? If you can zip the blend file and send it to me I'll take a look at what is going on.
Hi Doug

They are two separate files. I have not done any real 3d modeling. In the early days I played with gmax but didn't create anything just had a play around with the software. I have zipped the files. The texture files included are probably not the right texture size, they are just a quick get to work to see how things worked in blender.




  • Object file.zip
    325.1 KB · Views: 55

I'll let Doug do the heavy lifting 😁, but as far as exporting both of your files to .mdl, they export OK in Blender 3.6.

Here they are in MCX: