• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Newbie question regarding Blender 3.6.0


It appears that Dave was able to compile your 2 objects into models using v3.6. Do you remember if you installed the P3D SDK v1.4 after activating the toolset?

If you did install and activated the toolset prior to installing the SDK for P3D v1.4, this might have caused your problem. It is important that the installation of the SDK occurs before the toolset.

If this is the case, the toolset needs to be deactivated through the Edit tab ->Preference in Blender and removed (deleted) also. After you have done this, close Blender. Then load up Blender and install/ activate the toolset.

Your workflow on using the toolset:

You can create within Blender without having to use the toolset until you are ready to compile. When you are ready, you should 'initialize' the Toolset multiple times and proceed in adding the "Friendly name" and generating a GUID for this object. After that make sure textures are in their proper slots and change any variables. For good measure, It doesn't hurt to 'initialize" as you go through each of these steps. Of course, save before you compile (export) too.
Hi Doug

Thank you for your help and patience on this matter

Un installed the sdk and blender installed the sdk first ,blender than the tool set. Tried to export the cub untextured and got this error message
I have screen shoot the blender window to show the toolset installed




  • 2 error.jpg
    2 error.jpg
    100 KB · Views: 54
  • Blender window.jpg
    Blender window.jpg
    284.1 KB · Views: 45
This error is different from the others. It's referring to the fact that the object doesn't have any materials/ textures assigned. The object will not appear in FSX or Steam without textures.
Ninja'd by Doug!


What you need to do there is open the Shading window, click on material to add a material:


You will have this:


On the Material tab (1), you might have to scroll down to see the P3D/FSX Material Params dropdown (2). When you open that, select Specular Material (3):


Since you are only testing the exporter, you don't need to assign a texture. Just do the file export things.

The reason for that error is that you did not have a material assigned.

You can export an object without a texture, but it must have a material assigned.

But, the object won't appear in the sim without a texture.

I'm pretty sure this is covered in the wiki.
Thanks Dave and Doug

After following the above reply at last some success thank you.
The texture side of process I still need to get my head around, but getting there slowly.




  • pipes.jpg
    301.4 KB · Views: 46
Hi Rhys...

Wonderful! I'm glad for you. After the last error, I figured you would be successful. I should of been a little more detailed with the workflow on the textures. Sorry about that.

Thank you and Dave for your help. I really appreciate your patience and your time to help me out

You can see in my image that the pipes are transparent at the bottoms. Obviously its a texture issue. I am not sure how to go about setting the size of my texture to correspond to the size of my object.



I think maybe I am on the right track. select uv editing Exported uv to png save file then, open file in paint or other program place textures on png file save. In blender click material, base color select image texture and hopefully done

Question> Should I save the image as a bitmap in my paint program before I apply as texture to my object




  • test.jpg
    256.6 KB · Views: 46
  • Cylinder.png
    531.3 KB · Views: 45
Question> Should I save the image as a bitmap in my paint program before I apply as texture to my object
No, I would not. I would export it as a png file, as you did. The reason I would do as you did is because Blender works well with png files and not bitmaps and png files can have an alpha channel. In other words, png files use the alpha channel for transparency such as glass).

Just one warning on png files with an alpha channel, the older versions of Photoshop don't recognize png files with an alpha channel. GIMP does and has always allowed png files to have an alpha channel.
Thanks Doug

My model exports and shows up in the sim but the texture are not showing. As you can see in the image the textures are transparent at the bottom. I have followed the folder structure of the other lift able objects .I apply the texture in blender and they show on the pipe the images files are png files just not sure what I am doing wrong.

Are the textures converted to dds file format?

After the texture is converted, you can place them into blender also. What graphics editor are you using? GIMP or Photoshop? Both can convert them to dds. Convert to either dds5 or dds1 should work ok

Concerning the transparency, would need to see the textures to explain more.
Hi Doug

Im using gimp, here are the textures The textures aren't converted to dds



  • Cylinder.png
    532.8 KB · Views: 40
  • Tree02.jpg
    475.3 KB · Views: 41
Hi Rhys.

Ok. There shouldn't be any transparency because the textures aren't applied. After you have saved the textures as png you will then export as dds file format within GIMP. Since you are not needing any transparency, you can save as dds dxt1 but quality can be a factor using dds dxt1.

I will try to found images for you to follow later tomorrow.
Last edited:

Thanks Doug. Now I have the export to mdl sorted the texture side of things is proving a challenge. I searched you tube and came across lots of blender texturing and uv editing clips which I used to apply my texture correctly to my object, but they didn't mention dds dxt1 or getting textures to appearing in flight sim


Sorry, I had made a correction above.

nstead of save as you will export as a dds file. The Save as is only used to save using the GIMP file extension(.xcf).

Stay tuned. I will get images to you to follow.
Hello Rhys...

First, load up the png file of your texture in GIMP. Next, you will click on the 'File' tab and drop down to 'Export as'. A window will pop up (image 1):
At the top, at 'Name:' you will change the file extension to 'dds' and click on 'Export'. A new window will pop up (see next image):

Change the 'Compression' to either BC3/ DXT5 (as shown) or to BC1/ DXT1. Next, the 'Save' field will depend on your png file if it has multiple layers or just 1 single layer. Choose what would be best for your texture image. The next thing is very important and that is the "Flip Image vertically on export" boolean box. Make sure it is active or marked with an 'x'. Also, make sure to have 'Mipmaps generated', and last, click the 'Export' button.

You might want to create a '_lm' or Light map for your texture. This is also called the 'emissive' map. It is a texture or map that is used during the night in the sim. Within FSX and Steam, some objects don't appear unless a diffuse map and/ or an emissive map is applied... You can just copy the current texture for the diffuse and change the texture name with the added suffix of "_lm" to the filename. After you have done that, take the 2 files (one as the diffuse and light map) and place them in a texture folder that will accompany your mdl file (or bgl file)

I hope this better helps you in getting your test model to appear in Steam.

Pipes Away!!!

Thanks Doug re made the pipe and followed you last guide and texture is showing up. Still have that transparency issue but now I am on the home straight.

Thanks heaps



  • Pipes away.jpg
    Pipes away.jpg
    182.6 KB · Views: 45
For the transparent area, send the texture to me. Either the png or dds version, so I can see it.