• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Puddles still remain after the weather is fine.

jtanabodee

Resource contributor
Hi,
I have made puddles controlled by SODE. It worked just fine yesterday. But today I try it again. Turn the weather to clear sky but the puddles do not disappear. I was wondering what should be wrong.

<SimObject Name="WMKK">
<Placement Lat="2.7279000282" Lon="101.6877479553" Alt="21.337" Hdg="0.0"/>
<Model SimTitle="12bPilot_SODE_Environmental_Data_Probe">
<EnvironmentalDataProbe ClientList="Wind Sock;GP_KLIA2_Puddles;GP_WMKK_Puddles"/>
</Model>
</SimObject>

<SimObject Name="GP_KLIA2_Puddles">
<Placement Lat="2.727900028" Lon="101.687747955" Alt="0#AGL" Hdg="000"/>
<Model SimTitle="GP_KLIA2_Puddles">

<ConditionalVisibility Variable="MetPrecipitation" Value="RAIN"/>
</Model>
</SimObject>
<SimObject Name="GP_WMKK_Puddles">
<Placement Lat="2.748274170" Lon="101.708679199" Alt="0#AGL" Hdg="000"/>
<Model SimTitle="GP_WMKK_Puddles">

<ConditionalVisibility Variable="MetPrecipitation" Value="RAIN"/>
</Model>
</SimObject>
It seemed to work fine but now it is not working. I was wondering if anything wrong with XML.
puddles problems.jpg
 

jtanabodee

Resource contributor
I have found the answer. There is another paddle files in folder Scenery which I put to test how it looked like sometime in the past, but I forgot to remove it. I kept working of SODE folder, so I forgot all about that file.
 
Top