• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Split airport scenery to airport+harbour ->no texture for harbour

Messages
79
Country
france
Hello,

I trying to split in two my mod : https://flightsim.to/file/7185/lfeq-quiberon
one part with airport : I keep the same name : ailgorbot-lfeq (I remove the harbour)
second part with harbour : I rename it : ailgorbot-lfeq-port (I remove the airport)

<AssetPackage Name="ailgorbot-lfeq-port" Version="0.1.0">
<ItemSettings>
<ContentType>SCENERY</ContentType>
<Title>Port de Quiberon</Title>
<Creator>ailgorbot</Creator>
<Description/>
</ItemSettings>
<Flags>
<VisibleInStore>false</VisibleInStore>
<CanBeReferenced>false</CanBeReferenced>
</Flags>
<AssetGroups>
<AssetGroup Name="ContentInfo">
<Type>Copy</Type>
<Flags>
<FSXCompatibility>false</FSXCompatibility>
</Flags>
<AssetDir>PackageDefinitions\ailgorbot-lfeq-port\ContentInfo\</AssetDir>
<OutputDir>ContentInfo\ailgorbot-lfeq-port\</OutputDir>
</AssetGroup>
<AssetGroup Name="ailgorbot-lfeq-port-modellib">
<Type>ArtProj</Type>
<Flags>
<FSXCompatibility>false</FSXCompatibility>
</Flags>
<AssetDir>PackageSources\modelLib\</AssetDir>
<OutputDir>scenery\ailgorbot</OutputDir>
</AssetGroup>
<AssetGroup Name="myscene">
<Type>BGL</Type>
<Flags>
<FSXCompatibility>false</FSXCompatibility>
</Flags>
<AssetDir>PackageSources\scene\</AssetDir>
<OutputDir>scenery</OutputDir>
</AssetGroup>
</AssetGroups>
</AssetPackage>


In the Airport Editor the boats have their texture



I removed the airport




clean the package and rebuild

PackageBuilder | Validating Package 'ailgorbot-lfeq-port'...
PackageBuilder | Reloading assets for the package ailgorbot-lfeq-port...
Copying files from source folder F:\MSFS Projects\LFEQ-Port\PackageDefinitions\ailgorbot-lfeq-port\ContentInfo\...
Compiling texture file TEXTURE\CATAMARAN_0.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/CATAMARAN_0.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-catamaran.gltf...
Compiling texture file TEXTURE\JYLLAND.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/JYLLAND.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-jyland.gltf...
Compiling texture file TEXTURE\TALLSHIP.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/TALLSHIP.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-tailship.gltf...
Compiling texture file TEXTURE\TRIMARAN_0.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/TRIMARAN_0.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-trimaran.gltf...
Compiling texture file TEXTURE\VOILIER1_0.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/VOILIER1_0.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-voilier1.gltf...
Compiling texture file TEXTURE\VOILIER2_0.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/VOILIER2_0.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-voilier2.gltf...
Compiling texture file TEXTURE\VOILIER3_0.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/VOILIER3_0.PNG.DDS' for reloading.
Compiling GLTF data file ailgorbot-voilier3.gltf...
Compiling texture file TEXTURE\PHAREHALIGUEN_0.PNG...
VFS Bitmap Loader | Can not find 'vfs://ailgorbot-lfeq-port/scenery/ailgorbot/TEXTURE/PHAREHALIGUEN_0.PNG.DDS' for reloading.
Compiling GLTF data file phare-haliguen.gltf...
Copying files from source folder F:\MSFS Projects\LFEQ-Port\PackageSources\modelLib\...
Compiling BGL file from in-memory data to output file modelLib.BGL...
Compiling BGL from file objects.xml...
Compiling 1 SHP -> BGL (file shape.shp )...
PackageBuilder | Finished, 1 skipped, 21 done and 0 failed, took 15s452ms.
[BITMAP CONVERTED] 2D BM_BC3_UNORM 2048x1024 4926928146246695151
[BITMAP CONVERTED] 2D BM_BC3_UNORM 2048x2048 10597549893307474024
[BITMAP CONVERTED] 2D BM_BC3_UNORM 4096x2048 8195341848151136456
[BITMAP CONVERTED] 2D BM_BC3_UNORM 4096x4096 4937851365686630636
[BITMAP CONVERTED] 2D BM_BC3_UNORM 4096x2048 12772788199059574452
[BITMAP CONVERTED] 2D BM_BC1_UNORM 2048x1024 13539895791198387507
[BITMAP CONVERTED] 2D BM_BC3_UNORM 4096x4096 8947473653859745343
[BITMAP CONVERTED] 2D BM_BC3_UNORM 4096x4096 2090357649505049078

But when I put now the both package airport (ailgorbot-lfeq) + harbour (ailgorbot-lfeq-port) in community folder

All textures for harbour part are missing. For the airport it's ok.

ths ghost ship


I have also tried the trick by renaming in layout.json (modelLib.BGL) but it failed to fix the issue.

Any idea.
 
Last edited:
Top