• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 xml gage help needed

Messages
9
Country
us-arizona
I am in ther procees of creating an aircraft that has working spoilerons so the FSDS keyframe for the spoilers is used for it.

The aircraft also has speed brakes that would normally use the FSDS keyframe spoiler. How ever this would cause the speed brakes to act as the spoilerons will when deployed and the ailerons are used.

I have assigned the FSDS keyframe water_rudder_deploy to the speed brakes and they should deploy when the spoilerons are deployed as spoilers.

I have a gauge that works partially but not totally and I just can't figure out where the problem is I know it must be very visible but I just cant see it.

this this is the code I am currently using.


<Gauge Name="test"
Version="0.1">
<Update Frequency="6"/>
<Element>
<Select>
<Value>
(A:SPOILERS HANDLE POSITION,percent) 0 &gt;
if{ (A:WATER RUDDER HANDLE POSITION,bool) !
if{ (&gt;K:TOGGLE_WATER_RUDDER) }}
els{ (A:WATER RUDDER HANDLE POSITION,bool)
if{ (&gt;K:TOGGLE_WATER_RUDDER) }}
</Value>
</Select>
</Element>
</Gauge>

I really would appreciate any help solving this problem.

Thank you in advance
David wooster:confused:
 
Top