• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSX XML Tools 2.01 Win 10 Pro

Hello colleagues!

Ever since I got a new computer that came with Win 10 Pro, I have had difficulty getting the wonderful xmltools gauge to work properly. The gauge APPEARS to work, but all the LVARS are zeroes across the board. I tried "installing" the gauge using the installer, and it spins around for a second and disappears. I cross-checked the dll.exe file and the gauge looks like it's okay in the launch.addons in the entry, and if I use a flight on an airplane that has xmltools in the panel the gauge comes up but everything is zeroes. My previous computer had Win 10 Home and it worked fine there, but I can't understand why the gauge isn't reading LVARS. The LVARS DO work, because other gauges I created are working. But I can't understand this at all. I have the dll file in my main fsx folder, and the xmltools folder in "gauges," but for the life of me I can't figure out why I can't seem to see LVARS in the program. Can anyone advise? Thank you!
I have no idea, but people will probably need more detail. Post your LVAR file (if one exists), along with the dll.xml file entry.

Also note that the dll.xml file should be located in Users/[User Name]/AppData/Roaming/Microsoft/FSX, not the main FSX folder.
well, THIS is a total mystery to me. After weeks of using XML Tools (or trying to) and getting nothing but zeroes across the board, yesterday, for reasons known only to God, XML Tools started populating and now it works fine. I'm trying to bang my head against the wall and see if I removed a gauge or changed a setting, but I can't think of anything. i might have changed some abstract setting in fsx.cfg, but can't think of one, but it's sure great to have this tool back. Delving into the guts of what makes FSX work is still a major work in progress, and Im at the point now where SOME of the language in XML gauges are starting to make sense (which is why XML Tools is so valuable to me) and I'm smart-enough to know, despite James Cameron & Arnold Schwartzenegger, that my Win 10 Pro computer didn't just become 'self-aware," and that I obviously did something to remove the conflict but I don't know what...just super-glad to see it working again!