• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v3 1.78 Compile error

Hey guys. Just got my new system up and running and got 1.78 installed and I keep getting this error when I try to compile. I opened an already modified bgl. Any ideas? the error text is below. Never seen anything about "transparent" runways. I'm using the P3D V3 SDK.

This is the official version I'm using from the about tab.

Application 01.78.7298.19731
Engine 04.75.7298.19441

Using BglComp....


Parsing document: D:\ADE\!AdeTempWorkOnly\KBTV_ADEP3_md.xml

INTERNAL COMPILER ERROR: #C2033: XML Parse Error (line, column, error)

ERROR: 60, 33, The attribute 'transparent' on the element 'Runway' is not defined in the DTD/Schema.

INTERNAL COMPILER ERROR: #C2033: XML Parse Error (line, column, error)

ERROR: 186, 33, The attribute 'transparent' on the element 'Runway' is not defined in the DTD/Schema.

INTERNAL COMPILER ERROR: #C2606: Schema errors detected, compilation failed!
INTERNAL COMPILER ERROR: #C2034: XML Parse Fatal Error (line, column, error)

ERROR: 8397, 0, Validate failed.

INTERNAL COMPILER ERROR: #C2430: Unrecoverable error parsing XML!
INTERNAL COMPILER ERROR: #C2006: Parse failed (0x80004005)
INTERNAL COMPILER ERROR: #C2003: Failed to process file: D:\ADE\!AdeTempWorkOnly\KBTV_ADEP3_md.xml
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
The error usually arises based on the compiler being used but if you have it working in 1.79 then that is stable and can be used for any work
 
Yes and no. 1.79 works fine except for when the program first starts. The small window opens and askes for the sim to be designed for and the only thing you can click is the ok or the X in the corner. Ok kills the program and hitting the x allows the program to load but it won't connect to FSUIPC (1.78 does) so as a work around I open the airport in 1.78 then save my work, close and then open it in 1.79 to compile.
 

Attachments

  • error.jpg
    error.jpg
    40.5 KB · Views: 18
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
That error suggests that ADE cannot find any valid sims installed. It is not going to work correctly if that is the case. Can you confirm the version of FS/P3D that you are expecting to find - which one do you have installed?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
I don't have v3 installed and I am not sure if ADE 1.79 still supports it. Did you enter those path values into ADE yourself or did you use the Find button?
 
Last edited:

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Using find, it finds the scenery cfg but not P3D. It has a valid registry since every other installer finds it fine.
Yes but if ADE is no longer looking for v3 then it will not be found. It's just no longer supported by the latest version of ADE. We gradually drop support for old versions of P3D

ADE 1.78 supports P3dv3; ADE 1.79 does not
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Going back to the top post you report and error trying to compile a bgl file loaded into ADE. I might be able to see what is going on if you attach that bgl file to a post here
 
Going back to the top post you report and error trying to compile a bgl file loaded into ADE. I might be able to see what is going on if you attach that bgl file to a post here


As a test I opened a stock (grass strip) airport in 1.78. Added a runway link. One parking spot and appropriate taxi links to the airport including the hold short. Hit compile and I get the same error I pasted above about the "transparent" runway and not allowing a compile. SO I can't send a BGL since I can't get one to compile...
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
load the bgl file you started with into ADE. Save it as an ADE project (. ad4) and attach that to a reply here.
 
Top