• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Gpoly edges do not export

consta

Resource contributor
Messages
61
Country
cyprus
Hello everyone so I have been encountering this error. I have made edge polygons(lofts) for Gpoly . When I export it to MCX it does not show there when I load in the exported .X file into ground polygon wizard. Now if I import the file normally using the import option it loads up the same thing but if I go under the polygon (Upside down) it shows my edges perfectly but edge polygon in 3dsmax is not flipped or anything. I do not why this is happening any help would be appreciated!

in 3dsmax :

1559983783866.png


in MCX (gpoly wizard) :

No edges
1559983884373.png


in MCX (Normal Import) Upside down view :

1559983930956.png
 
Messages
5,214
Merge the 2 mdl's if not done already and then make sure the edge material has a higher (more negative) layer when using the GPW.
 

tgibson

Resource contributor
Messages
10,232
Country
us-california
Hi,

If your polys are not flat on the ground they are probably being removed by the ground poly wizard. There may be a setting for that, but they probably should all be flat on the ground, I believe?
 

consta

Resource contributor
Messages
61
Country
cyprus
Merge the 2 mdl's if not done already and then make sure the edge material has a higher (more negative) layer when using the GPW.

They are in one file ,tried higher values it didnt work

Hi,

If your polys are not flat on the ground they are probably being removed by the ground poly wizard. There may be a setting for that, but they probably should all be flat on the ground, I believe?
Hi I have them at ground at 000m they still dont appear in GP wizard
 

consta

Resource contributor
Messages
61
Country
cyprus
So I tried increasing the size of lofts but the issue is still unsolved they are messed up when I try to import them on gpoly wizard however the weird thing I noticed is when I import normally using import it appears there without any error but if I import it again it shows this mess again and also it loads up for a second it shows my edges correctly in gpolywizard but in a sudden it just hides and shows this little messed up polygon
1560177692200.png
 
Messages
5,214
Once you have made sure that the 3DS Max model is flat, load it in MCX. Look at the grid to see if it is really the case (like Tom said) . If not, you can always use the 'move' option to lower it to 0 alt. You can check if it is OK in the Object information tab where the Z axis should be both at min and max 0. Then compile the model again before you use the GPW.
Are you sure you did not assign various layers already in 3DS? Does MCX show only one mdl and not two?
You could send us the mdl if you do not manage to get it right and see what is the matter with it and provide (probably) some solution.
 

consta

Resource contributor
Messages
61
Country
cyprus
Once you have made sure that the 3DS Max model is flat, load it in MCX. Look at the grid to see if it is really the case (like Tom said) . If not, you can always use the 'move' option to lower it to 0 alt. You can check if it is OK in the Object information tab where the Z axis should be both at min and max 0. Then compile the model again before you use the GPW.
Are you sure you did not assign various layers already in 3DS? Does MCX show only one mdl and not two?
You could send us the mdl if you do not manage to get it right and see what is the matter with it and provide (probably) some solution.


Hey, I have checked they are on the grid and flat.
The alt is already 0
Z-axis min and max are also 0

I didn't get your point about assigning various layers. I usually just work on workspace without changing anything and making all the polys on that.
I export it as .X file using p3d sdk for 3dsmax so its one file and not two (so I am not sure how MCX would show 2 mdl files however its just one file)
after following what you mention it still didn't work.
I am attaching it below the .x file in a zip which I export from my 3dsmax of the edge.
 

Attachments

  • Gpoly.zip
    18.5 KB · Views: 98
Messages
5,214
From what I can see in the x file, is that you have one mdl with a material called 'edge' with a Z-bias of 8 (= what I call 'layer'). Export as an object to make it a P3Dv4.4 mdl (not sure if this is necessary).
Import in the GPW and set this material layer to (e.g) -32 and see if it now shows up above the polygon.
 

consta

Resource contributor
Messages
61
Country
cyprus
From what I can see in the x file, is that you have one mdl with a material called 'edge' with a Z-bias of 8 (= what I call 'layer'). Export as an object to make it a P3Dv4.4 mdl (not sure if this is necessary).
Import in the GPW and set this material layer to (e.g) -32 and see if it now shows up above the polygon.
I tried it, unfortunately, it didn't work.
 
Top