• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Jetway issues

Messages
45
Country
unitedstates
Arno,

I just built a jetway in fsds animated it there so when I converted the model with conveter x using a .x or an mdl file to a 3ds file I could import to Gmax. I reanimated the jetway using Gmax, I pute a condition on the jetway using the first interface screen in cat with 110.80 110.90 nav1 nav2 to triger after I triger I get the same issue what can I due to fix the problem and I am at over 30 fps so I can't see that being my issue.


Donald miller
drmiller21@live.com:confused:
 
Hi,

Why do you use a condition and a trigger? Is only a trigger not enough?

Send from my phone using Tapatalk, so excuse the short sentences and possible typos
 
trigger and condition

Hi Arno,

I don't know that is what i did on the first jetway I got from turbosquid and it seemed to work just fine you would pull up to the jetway and input nav 1 nav 2 and and it would play the animation smooth I guess I just thought that it would be better that way. With the new jetway even with the conditions I get one continues loop as if there were no trigger or condition. could you look at my .asm to see if it can be fixed? if so I have included them as an attachment
 

Attachments

  • KPSC_Terminal_Jetway_DRM_cat.asm
    4 KB · Views: 453
  • KPSC_Terminal_Jetway_DRM_cat_0.asm
    236.1 KB · Views: 596
  • KPSC_Terminal_Jetway_DRM_cat.mdl
    54.1 KB · Views: 642
Hi,

When I look at the source, I don't see the code for the trigger indeed. Often that means that CAT does not recognise the animation.

You used FSDS you wrote, right? Which version of CAT are you using? I remember some versions had issues with the ASM files made by FSDS.
 
Fsds

hi arno

Thank you for looking at the asm code


I used fsds version 3.0 to create the model I then imported the jetway to a 3ds file and imported to Gmax. I animated it with Gmax and created the asm file with Gmax. I did how ever add animations to it before the export to Gmax as that seemed to be the only way, I could keep my model broke in to individual parts for animation if I did no animation in fsds and imported to gmax it made it one solid piece and could not be broke up for animation. could that have caused the issue or could it be that I need a dummy helper box as I did not add one on this animation which is something my turbosquid jetway had.


donald
 
Hi,

Humm, with gmax it should not be a problem.

Are you sure you added a trigger? If you only added the animation condition it would indeed loop.

Send from my phone using Tapatalk, so excuse the short sentences and possible typos
 
condition

Hi, arno

This is what I did, i added just what you see in the picture. I added the values on the first screen I skipped the seconded screen as I used to values on the first page I assumed that was enough to trigger the animation. the funny thing is I animated the turbosquid jetway the same way and it worked fine with out the loop after the conditions were turned on. I will add a trigger now that you said that is probably the problem


donald
 

Attachments

  • Cat conditions.jpg
    Cat conditions.jpg
    51.6 KB · Views: 623
Fixed

Arno,


the jetway is fixed and you were right I did not add a triger just the condition and that was the problem. the jetway now works the way it should thank you sir. for all your help.


donald
 
Glad to hear it works now.

Send from my phone using Tapatalk, so excuse the short sentences and possible typos
 
Back
Top