• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v4 Kinda lost

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Google.Drive was unable to decompress the file. I don't need your background images.

Following receipt of your earlier file set, I summarized the results of my analysis - which indicated further work on your part was needed - and added:
I would suggest you go back to "Square 1" - including removing the PAPI from ADE's object library - and follow the process laid out in the user manually religiously. If it still doesn't work. please send me the same set of files along with a narrative of what you did.

Did you do what I suggested? If so and the PAPI still doesn't appear where you specified, I need to know what changes you made, the details of your process, the results and copy of the latest fileset. I only asked for the .ad4 file if, after doing so, the PAPI was not in the right place. You've provided none of this. Indeed, you haven't even confirmed whether or not the PAPI as it appeared in the screenshot I sent to you was properly located (i.e., where you specified in ADE. It has nothing to do with where it appears on your background images.

I know that AIFP works if used as intended. I've created custom lighting for 6 airports with the latest version. So, if it's not working for you, then I can only conclude you are not using it as intended. Therefore, I need to know what you have done and how you have done it. Also, there is no way I can diagnose the mis-matched guid situation with ADE. Until that is resolved and you send me what I asked for, there litte more I can do.;

Don

EDIT: I was able to open your .ad4 file with another browser. (Google.Drive with IE was unable to do so). Matching my screenshot with the compiled .ad4 file, the PAPI (in the screenshot) appears exactly where you put it.
 
Last edited:
Messages
269
Hey,
Managed to get it to work!
https://prnt.sc/i2d0xi

I followed the manual and found out that I forgot to copy the created library file to the scenery folder..

By the way, is creating def file is the same as placing lights in ADE? I mean, do you get the same results?

Thanks,
Bar
 

gadgets

Resource contributor
Messages
9,388
Country
ca-britishcolumbia
Managed to get it to work!
That's great! But, are you using PV4 or some other version of FlightSim? If the former, I don't understand why it's now working since the PV4 doesn't need that library file - unless, of course, Pv4.1 reinstates some legacy technology. (I didn't use that library file when I tried your earlier file set and successfully displayed the PAPI.) If you are using FS9 or FSX, however, that file is definitely required.

A .def file contains positioning information (same as the ADE file) but offers certain shortcuts for what would be necessary otherwise in an ADE file. You can easily specify a whole approach array in a .def file. Doing so in ADE would necessitate a lot more work with less precision.

Don
 
Messages
269
That's great! But, are you using PV4 or some other version of FlightSim? If the former, I don't understand why it's now working since the PV4 doesn't need that library file - unless, of course, Pv4.1 reinstates some legacy technology. (I didn't use that library file when I tried your earlier file set and successfully displayed the PAPI.) If you are using FS9 or FSX, however, that file is definitely required.

A .def file contains positioning information (same as the ADE file) but offers certain shortcuts for what would be necessary otherwise in an ADE file. You can easily specify a whole approach array in a .def file. Doing so in ADE would necessitate a lot more work with less precision.

Don
Hey,
I am using P3D V4.1. I took the library file out of the scenery folder and it still works so I guess the issue was with my messy AFLT For P3D folder in the P3D Addons folder..
 
Messages
269
By the way, I am trying to create my own PAPI model because I need less space between the lamps than in the supplied model. I edited the supplied model and created my own one with spacing that I need. I entered it into the list, but when I click on "Create/Save Element" I get the following error: "Unable to add animationns to .mdl file 'LLHAPAPI'". Any ideas way?
 
Top