• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSXA Problem with DSD Sound gauge

Im trying to get a sound to play, but keep getting an error that the gauge cant find the sound file.
But, the error is saying it cant find the sound file, right where i put it !?

Different locations throw the same error

but there it is staring me in the face :


My PANEL file entries :

Background_color = 0,0,0
size_mm = 1024,1024
visible = 1
pixel_size = 1024,1024
texture = $vc_gxml_lm
gauge00 = L049_Illumination!gauges1, 0, 0, 1024, 1024
gauge01 = Gauges\dsd_fsx_xml_sound!Sound, 2,2,2,2,.\Gauges\dsd_fsx_xml_sound.ini

My INI :


Sound01= D:\FSX\Sound\LM\lm_xml_01.wav


Both [sound] entries dont work...wether a '.\' , or a '.' or '\' is used.

Spent a whole day going back and forth with this , and it just wont work.
Please help!
I would check the file itself... the error says it's an invalid file... not a missing file. What does the Full Error Code of 0x110 actually mean?
Hey WarpD :)

not able to get much info from googling the error code...only the info in the window in the pics i posted.

I don't understand why its complaining it's invalid, the second pic shows the error saying it cant find the file/ invalid...but as you can see it is right there in windows explorer.

very confused.

Delete the files and re-do them?

Thanks for replying.
It isn't stating it can't find the file, it's stating it's not a valid audio file. If it couldn't locate the file, it would return a MMIOERR_FILENOTFOUND error. There is something about that audio file it doesn't like. The only thing I can find regarding your error is this blurb from Microsoft:
Another failure condition occurred. This is the default error for an open-file failure.
Not very useful... but it definitely means it doesn't like the audio file.
I've had a little investigation and you are 100% correct.
I changed the file location within the INI to another file in the sounds folder in Fsx, and it worked.
Changed it back to mine, failed.
Put my sound, in the working sound file, failed.
Put a sound from the working file into my file - success.

So if my audio file is in any folder, it fails.

Thanks WarpD - at least i know its now the audio file and not my panel edits/INI file or such.
I wonder whats up with the audio file..