• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FSX Slowing Down Animation

I'm sure I'm missing something. Is there a quick way to slow down an animation other than changing the timings on all the frames ? I have an animation with six parts, each with 100 frames, so that will take a while !

I thought changing the Length might do it, but that doesn't seem to have an effect..

I'm using MCX 1.40 latest stable release.
 
OK. I bit the bullet and changed the timing on all the frames in the animations I want to slow down. All 600 of them. I increased the timing on each one so that the timing between them was 5.0 instead of 1.0. And in MCX the animation of all the parts runs from start to finish at an appropriately slower rate.

However, in FSX, although the animation runs at the same slower rate, it doesn't complete. I'm guessing it stops at about a point about 20% through.

In other words, it runs for the same duration it did before, but stops before it completes because it is slower.

The animation is lever_speed_brake. It is mapped to the bomb doors on this a/c.

How do I fix this ?
 
Last edited:

tgibson

Resource contributor
Lever speed brake is limited to 100 keyframes. AFAIK that can't be changed.

That is specified in the SDK:

Animation Tags
lever_speed_brakeAirbus_A321_interior100 keyframes

In the modeldef.xml file:

<PartInfo>
<Name>lever_speed_brake</Name>
<AnimLength>100</AnimLength>
<Animation>

In that entry is the following line:

<Lag>200</Lag>

which determines how fast it moves.

You might be able to create a copy of this entry with a name like bomb_bay_doors, assign that in MCX, and increase the lag? Or perhaps you could create another entry in the modeldef file with a greater AnimLength and assign that in MCX instead?
 

=rk=

Resource contributor
This is from the default A321.

[exits]
number_of_exits = 3
exit.0 = 0.4, 45.50, -6.0, 7.0, 0 //openclose rate percent per second, longitudinal, lateral, vertical positions from datum (feet), type (0=Main 1=Cargo 2=Emergency)


We can see that the first value controls the rate the door cycles. If you can get your animation into this form of an entry in the aircraft.cfg, you can change it's speed.
 
Hi guys - thanks for this useful input.

I had already started down the road of playing with the lever_speed_brake entry in modeldef, and there do seem to be some hard-coded restrictions. Changing the Lag parameter makes no difference - it just gets reset to 200 when the model is compiled (you can see it in the MCX modeldef). You can change the length/animation length, and it stays changed, but again it seems to make no difference.

(BTW I'm not entirely sure what the Length parm means - is it the number of frames or the duration of the animation ? When I re-timed the 100 frames in MCX to have a +5 gap between them instead of +1, MCX automatically sets the length to 500, the value of the last frame. You can change this, but MCX resets it to 500 when the model is compiled.)

However, i have had some success based on your suggestions. I re-assigned the animations to door_0, and now the bomb doors work fine, even using the original animation timings. The only problem is that to activate them I have to use the Doors Open/Close control (Shift+E). Somehow I need to map them to the Spoiler control. I've tried editing the door_0 entry in modeldef to use the Spoiler lever position, but that just flips the doors open and close. Adding a Lag entry doesn't help, and the cfg entries Rick mentions don't seem to make a difference either (I suspect they only work if if Shift+E is used).

But that's good progress - thanks guys. I need to play some more. :)
 
You might be able to create a copy of this entry with a name like bomb_bay_doors, assign that in MCX, and increase the lag?

Bingo. I did just that and it worked. I added the following to modeldef:

<Animation name="Bomb_Doors" guid="43926dbf-026d-4df0-ab72-5414037b8bdb" length="100" type="Sim" typeparam2="Bomb_Doors" typeParam="AutoPlay"/>


<PartInfo>
<Name>Bomb_Doors</Name>
<AnimLength>100</AnimLength>
<Animation>
<Parameter>
<Sim>
<Variable>SPOILERS HANDLE POSITION</Variable>
<Units>percent</Units>
</Sim>
<Lag>20</Lag>
</Parameter>
</Animation>
<MouseRect>
<Cursor>Hand</Cursor>
<HelpID>HELPID_GAUGE_SPEED_BRAKE</HelpID>
<TooltipID>TOOLTIPTEXT_SPEED_BRAKE</TooltipID>
<MouseFlags>LeftSingle+LeftDrag+Wheel</MouseFlags>
<CallbackDragging>
<Variable>SPOILERS HANDLE POSITION</Variable>
<Units>percent</Units>
<Scale>163.84</Scale>
<YScale>163.84</YScale>
<MinValue>0</MinValue>
<MaxValue>16384</MaxValue>
<EventID>SPOILERS_SET</EventID>
</CallbackDragging>
</MouseRect>
</PartInfo>


The <Partinfo> section is an exact copy of the lever_speed_brake <partinfo> with the Lag parameter changed from 200 to 20. This didn't work for lever_speed_brake, but does work for the renamed copy. Fascinating.

Thanks Tom ! (Again)
 
Top