• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

[SOLVED] Material Editor Bug

Messages
122
Country
germany
Hi Arno,
I found a bug in the latest development release (Downloaded MCX today 03/25/2019).
When adding a new material template from an existing material and then close the Material Template Editor window, I get the following error:

mateditorbug.png


In English: "The process cannot access "C:\FlightSimulation\...\New_Template1.mcxmat" because it's used by another process."
Furthermore I saw in the corresponding folder that many of my old existing material templates had been deleted.

The same happens each time I want to make a new template from an material of the model (doesn't depend on a particular material).

Thanks!
Volker
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,632
Country
netherlands
Hi,

Somebody else reported something similar, but I haven't been able to reproduce it yet. I haven't changed anything recently in how templates are saved.

Did you have two instances of MCX active at the same time?
 
Messages
122
Country
germany
No, just one instance...

mcxbug2.jpg


Please tell me, if I can help by sending some log files etc.

Thank you, Volker
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,632
Country
netherlands
Hi,

I tried to reproduce it here, but I can't. I can create a new template without problems, no error when closing the template editor.

The error in the second screenshot does that also happen when you close the template editor?
 
Top