• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Aerial Images (Airport Background)

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,125
Country
us-wisconsin
Yes. I think 32-bit PNG is the standard. 32-bit includes the Alpha channel.
 
Messages
10
Country
unitedkingdom
Hi Guys,

I have solved the problem with the green tinge I was having with imported imagery. You will need to add the alpha channels to your tiles in order for it to display correctly.

I used imagemagick to do this as a batch script by running the following from the directory where your tiles are located:

Code:
FOR %a in (*.png) DO magick convert %a -alpha on %a

You can check if the alpha is missing by using the following code replace [filename.png] with one of your tiles to test:

Code:
magick identify -verbose [filename.png]

If the type is TrueColor and not TrueColorAlpha you will need to add the alpha channel.

You will need to install imagemagick in order for this to work.

You wonderful person! Thank you for this. I had a feeling it was something to do with channels but I'm not yet advanced enough to figure it out! Brilliant solution!
 
Messages
7
Country
australia
You wonderful person! Thank you for this. I had a feeling it was something to do with channels but I'm not yet advanced enough to figure it out! Brilliant solution!

No worries,

If you find out how to colour correct your imagery properly let me know, thats where i'm stuck now! :D

I've tried colour-correcting against bing, and also a screenshot from inside the sim but no luck.
 
Messages
10
Country
unitedkingdom
No worries,

If you find out how to colour correct your imagery properly let me know, thats where i'm stuck now! :D

I've tried colour-correcting against bing, and also a screenshot from inside the sim but no luck.

Yeah its really strange. I've checked the imagery URLs that the sim is hitting and they are the same as the standard Bing/VirtualEarth URLs, which logically means that if you colour correct against those same URLs then you should be golden, but the thing is it's just not the case. I'm 99% certain at this point that the sim is applying a shader to the secondary aerial images which is causing the discolouration but I can't be 100% certain without confirmation from Asobo/MS.
 
Messages
258
I'v managed to compile and image but as I saw in earlier messages in this post the original image is displayed when you get close to the ground. Any ideas?
 
Messages
10
Country
unitedkingdom
Have you checked the tile debug? Maybe it is some useful information in there.

Thank you for this, you actually gave me a great idea. You can find out the "gen" number that sim is using and adjust your QGIS URL and load in the same generation of tiles as the sim is using. Once you've done that it should be only a matter of using the correct generation of tiles to apply colour corrections to your new Ortho! Finally a reference image available outside of the sim!!

Separately to this but on the subject of Orthos. When MS/Asobo eventually update the region your scenery is in, we're likely going to have to update our Orthos colour corrections all over again.... Perhaps using an external Ortho is not such a good idea in this sim...
 
Messages
10
Country
unitedkingdom
I'v managed to compile and image but as I saw in earlier messages in this post the original image is displayed when you get close to the ground. Any ideas?

Did you compile for LOD20? That is the highest the sim will do, and when you build the package all other LOD levels are create for you from 20.
 
Messages
181
Country
germany
Thank you for this, you actually gave me a great idea. You can find out the "gen" number that sim is using and adjust your QGIS URL and load in the same generation of tiles as the sim is using. Once you've done that it should be only a matter of using the correct generation of tiles to apply colour corrections to your new Ortho! Finally a reference image available outside of the sim!!

Separately to this but on the subject of Orthos. When MS/Asobo eventually update the region your scenery is in, we're likely going to have to update our Orthos colour corrections all over again.... Perhaps using an external Ortho is not such a good idea in this sim...

You might want to share a few screenshots on that? Sounds interesting.

I don't think updates will happen too often. Considering, the pics now on bing are up to ten years old. Maybe you have to color correct a bit or in the best case you can get rid of your image, if the bing image is better at that point.

Did you compile for LOD20? That is the highest the sim will do, and when you build the package all other LOD levels are create for you from 20.

Yes I used LOD20.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,125
Country
us-wisconsin
Using the alpha channel to mask off areas sometimes eliminates the need for color correction. Choose a fenceline, or road as the limits of your aerial image and just leave the airfield or neighborhood. It will hide among the default with little need for a color change. Photoshop, Gimp, or paint.net all allow export of images as 32-bit PNG. That is RGBA.
 
Messages
7
Country
australia
Using the alpha channel to mask off areas sometimes eliminates the need for color correction. Choose a fenceline, or road as the limits of your aerial image and just leave the airfield or neighborhood. It will hide among the default with little need for a color change. Photoshop, Gimp, or paint.net all allow export of images as 32-bit PNG. That is RGBA.

That's what I ended up doing seeing as my source imagery is completely different colour-wise to bing's, and the results turned out ok, however still not 100% satisfied. I am having problems with trees changing colour based on the underlying imagery, shown in the photo below.

Thank you for this, you actually gave me a great idea. You can find out the "gen" number that sim is using and adjust your QGIS URL and load in the same generation of tiles as the sim is using. Once you've done that it should be only a matter of using the correct generation of tiles to apply colour corrections to your new Ortho! Finally a reference image available outside of the sim!!

Separately to this but on the subject of Orthos. When MS/Asobo eventually update the region your scenery is in, we're likely going to have to update our Orthos colour corrections all over again.... Perhaps using an external Ortho is not such a good idea in this sim...

That sounds like a great solution, seeing as trying to get an imagery from the sim to adjust to ends up a blurry mess when zooming out. Are you able to explain how you added the new source to QGIS?
 

Attachments

  • tree_colour.jpg
    tree_colour.jpg
    427.3 KB · Views: 282
Messages
11
Country
france
Someone know if is it possible to rename an aerial tiles?? Because for close aerial project, .cgl files names are the same... I'm stuck at this point.... Thank for your answers
 
Messages
766
Country
unitedstates
Someone know if is it possible to rename an aerial tiles?? Because for close aerial project, .cgl files names are the same... I'm stuck at this point.... Thank for your answers

These I believe are based on Bing formatting and cannot be changed.

BTW I started scanning this thread and what a complicated process. There's a much easier way by using something like Global Mapper or QGIS to process out to Bing format. Input data, output data, run through the SDK tools and done.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,125
Country
us-wisconsin
The new 0.6.0.0 SDK has some changes. For aerial imagery, the Simple Aerial sample, PackageDefinitions/ mycompany-aerial.xml has changed.

The old XML:
XML:
<AssetPackage Name="mycompany-aerial" Version="0.1.0">
    <ItemSettings>
        <ContentType>CORE</ContentType>
        <Title/>
        <Manufacturer/>
        <Creator/>
    </ItemSettings>
    <Flags>
        <VisibleInStore>false</VisibleInStore>
        <CanBeReferenced>false</CanBeReferenced>
    </Flags>
    <AssetGroups>
        <AssetGroup Name="Secondary aerial">
            <Type>CGL</Type>
            <Flags>
                <FSXCompatibility>false</FSXCompatibility>
            </Flags>
            <AssetDir>PackageSources\CGL\</AssetDir>
            <OutputDir>CGL\</OutputDir>
        </AssetGroup>
    </AssetGroups>
</AssetPackage>

The new Simple Aerial sample, PackageDefinitions/ mycompany-aerial.xml:
Code:
<AssetPackage Name="mycompany-aerial" Version="0.1.0">
    <ItemSettings>
        <ContentType>CGL</ContentType>
        <Description/>
    </ItemSettings>
    <Flags>
        <VisibleInStore>false</VisibleInStore>
        <CanBeReferenced>false</CanBeReferenced>
    </Flags>
    <AssetGroups>
        <AssetGroup Name="Secondary aerial">
            <Type>CGL</Type>
            <AssetDir>PackageSources\CGL\</AssetDir>
            <OutputDir>CGL</OutputDir>
        </AssetGroup>
    </AssetGroups>
</AssetPackage>

Note the content type has changed from Core to CGL. We'll see what this changes.
 
Messages
766
Country
unitedstates
The new 0.6.0.0 SDK has some changes. For aerial imagery, the Simple Aerial sample, PackageDefinitions/ mycompany-aerial.xml has changed.

The old XML:
XML:
<AssetPackage Name="mycompany-aerial" Version="0.1.0">
    <ItemSettings>
        <ContentType>CORE</ContentType>
        <Title/>
        <Manufacturer/>
        <Creator/>
    </ItemSettings>
    <Flags>
        <VisibleInStore>false</VisibleInStore>
        <CanBeReferenced>false</CanBeReferenced>
    </Flags>
    <AssetGroups>
        <AssetGroup Name="Secondary aerial">
            <Type>CGL</Type>
            <Flags>
                <FSXCompatibility>false</FSXCompatibility>
            </Flags>
            <AssetDir>PackageSources\CGL\</AssetDir>
            <OutputDir>CGL\</OutputDir>
        </AssetGroup>
    </AssetGroups>
</AssetPackage>

The new Simple Aerial sample, PackageDefinitions/ mycompany-aerial.xml:
Code:
<AssetPackage Name="mycompany-aerial" Version="0.1.0">
    <ItemSettings>
        <ContentType>CGL</ContentType>
        <Description/>
    </ItemSettings>
    <Flags>
        <VisibleInStore>false</VisibleInStore>
        <CanBeReferenced>false</CanBeReferenced>
    </Flags>
    <AssetGroups>
        <AssetGroup Name="Secondary aerial">
            <Type>CGL</Type>
            <AssetDir>PackageSources\CGL\</AssetDir>
            <OutputDir>CGL</OutputDir>
        </AssetGroup>
    </AssetGroups>
</AssetPackage>

Note the content type has changed from Core to CGL. We'll see what this changes.

So is there a way to manually run the compiler outside the sim? I hate that in sim it gives no idea it’s doing anything.
 
Messages
426
Country
us-newyork
So is there a way to manually run the compiler outside the sim? I hate that in sim it gives no idea it’s doing anything.
fspackagetool.exe? It actually builds a project by running the sim without the UI.

Within the sim, if one opens the console window before building a package, you'll get a ton of messages. Some of them are even useful.
 
Messages
766
Country
unitedstates
fspackagetool.exe? It actually builds a project by running the sim without the UI.

Within the sim, if one opens the console window before building a package, you'll get a ton of messages. Some of them are even useful.

I open the console before running the tool, it shows nothing until it’s finished processing when it comes to aerial imagery, if it does finish. It seems to choke if an area is too big.
 
Last edited:
Top