• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Blender 3D Model missing texture in the MSFS Editor

Dear FSDeveloper Forum,
I have been using the SDK Editor for MSFS for some time now and understand it really well.
Now I wanted to try to export a 3D Model into the simulator.
I followed multiple tutorials and guides.
The model shows up in MSFS but it is really thin and it is missing it's texture.
I have set the Material to the MSFS Material Params.
The texture is also being exported to the right path. The texture file has a size of 4096px * 2048px. I tried with the texture as a JPG and a PNG file.
How can I solve these two problems?
(I called the 3d model half-sausage so that it would be easier to find :) )


  • 22_03_2024_1.png
    907.5 KB · Views: 48
  • 22_03_2024_2.png
    1 MB · Views: 48
  • 22_03_2024_3.png
    55.9 KB · Views: 52
Can you zip the .blend file and textures (if they are not packed), and attach that to a post?
Here is the .blend file and the texture


  • souda-models.zip
    3.3 MB · Views: 32
Sorry for the delay. Your object has a modifier. So you either need to Apply the modifier to the object in Blender, or tick the Apply Modifiers Box in the Asobo Exporter (which applies all Modifiers in the export... a best practice anyways). That applies the Solidify to the mesh, and fixes the thin issue.
The texture needs to be in a Modellib texture folder. You seem to be exporting it to textures.
Thank you for your reply. It worked!
Now there is still one last problem. One old thin model is still in the Editor.
I can't click on it and it is nowhere to be found in the Scenery editor.
How can I get rid of it?
Make sure the old model is not in your ModelLib source (and not in Community). Recompile. Exit the sim. Restart the sim and go to your airport, Reload the scenery in DevMode. The thin model will be gone.
This has been a problem with the Devmode from day one.