• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Invalid file X

Hi everyone,

I tryed to convert a file .mdl and ModelConverterX v1.4 reported this error:


I saw that MCX doesn't create the file .X

How can I fix it?

Thank you,

I think there is some attach point or texture name in the X file with a weird character, that's probably why xtomdl gives the error.

MCX will cleanup the temp X file automatically, that's why you won't see it.
Hi Arno,

I converted the file with MCX 1.3 and it worked. Now with the 1.4 it doesn't work. I checked if there are some files with weird character but nothing.

Version 1.3 is very old, it did not support skin and bone animations for example or many other features. So part of these differences could also affect the error.

But if you have the X file made by version 1.3 and the one made by 1.4 we can maybe compare them to see what the issue is.
Hi Arno,

this is the .x of the version v1.40. I haven't the v1.30 because I change it with the v1.40

This is a temp file beacuse the it doesn't create the final .x file

I tryed with and other file and it works. So I think that is file .mdl the problem


  • tmp15FE.zip
    235.4 KB · Views: 116
Last edited:

I can confirm I get the same error here. But at first look I see nothing wrong with the X file. I'll see if I can find the cause of the error later.

I think the problem is the space that you used in the attachpoint name. When I replace that with an underscore the object compiles fine.