• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Wrong Season Loads on Ground Poly

RicherSims

Resource contributor
Messages
571
Country
dominica
I used MCX to add seasons to my Ground Poly. But whenever I reopen the BGL and set BGL_ZULU_DAY to anywhere between 335 and 31, instead of Fall textures, Winter is loaded. Same thing happens in sim. All other seasons work fine. Any ideas?

wrong seasons.png
 
Hi,

Can you send me the SCASM output that is generated? Then I can check what is going on.
 
Never had a look at SCASM before but a quick look into the file reveals that the value range for 335 to 31 does not exist anywhere. Hope you can figure out why.
Along with the SCASM file, I've also attached the model I used and it's MGP file for the wizard in case you wanted to take a look.
scasm.png
 

Attachments

  • 8_tpbpv2_photo_RS_seasonal.zip
    47.7 KB · Views: 248
Thanks, I'll check. The season that crosses new year is used as else condition and not mentioned explicitly.
 
Didn't have the time yet to check the code.
 
I found the error in the scasm code @arno .
Read through some threads and wikis and learnt the code. Turns out the "else" part of the code was calling the wrong material set. For example: 4, 12, and 20 were all WI textures for the first 3 polygons. When I changed them to 6, 14, and 22 and recompiled, the correct FA textures were called in the BGL. Turns out the fall and winter values were switched for some reason.

I hope you can figure out what caused the wrong material call in the first place. I'm off to change the rest of the values.

Good luck.
Regards,
Zev.
 
Last edited:
Sounds like a bug in the GPW, I'll check what is going on.
 
Hi,

I have found the bug in the code, so it will be fixed in the next build. There was indeed an issue when another season than winter was the one that span over the year border.
 
Back
Top