• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 MCX Bgl compiling help - INTERNAL COMPILER ERROR C1003 [FIXED]


Resource contributor

I am new to MCX and object design in general.
I wanted to make a test to see if I could understand and get the hang of the process of creating bgl objects for placement in FS9 from models created with other tools; So I got a model of a building made in SketchUp that I'd like to make the test with.
I then proceeded to follow this tutorial from step 12 and beyond: http://www.calclassic.com/sketchup_tutorial.htm
Got the model looking nice in MCX, converted the textures successfully to BMP.
Next step would be making the bgl file of the model; enter my problem. Some errors occur (see attachment).
Now, I googled and looked around for a fix for this and found some possible solutions such as the ones mentioned here: https://scruffyduck.screenstepslive...ler-error-c1003-failed-to-create-msxml-object
and here: https://www.fsdeveloper.com/forum/threads/compile-error.21487/
I already had MSXML4, but I uninstalled and re-installed anyways, twice, but the same errors keep occurring :/

Can anyone help me figure this out?




  • errors.PNG
    22.3 KB · Views: 430
I checked the supposed install location folder for MSXML 4.0 (C:/Program Files (x86)/MSXML 4.0), but could only find a rich text file that lists the eula, no dll file, nothing else.
Could this be the issue and I have a bad installer? Or is this how it is supposed to be and the relevant files are installed in another folder concerning the system itself or something? (I know next to 0 regarding the installation of files of this nature so pardon my ignorance)

This is for sure a problem with MSXML not being installed correctly. But for me just running the installer always was enough.
Hey arno,

Do you, or anyone else reading this knows where the installer puts all the relevant files in Windows 7 64-bit? Just so that I could confirm that the installation was done properly.



You may wish to check and make sure you installed the MSXML version required for FS Development that is also compatible with Windows 7:



Also see:


I have this version installed on a laptop used for both FS9 and FSX development with ADE & MCX; I do not get errors reported in the OP above:

"MSXML 4.0 SP3 Parser - Microsoft Corporation Product version: 4.30.2100.0"


Last edited:
Hey Gary,

Well I read all your links, and followed the troubleshooting suggested in the 2nd link you provided.
Imagine my surprise when I am confronted with the fact that there is no msxml4.dll & msxml4r.dll in my C:/Windows/System32 folder as it was supposed to. The only msxml dll files that were there were msxml3.dll, msxml3r.dll, msxml6.dll & msxml6r.dll, which I assume pertain to version 3 and 6 of MSXML respectively...
This was AFTER installing the msxml 4.0 with the installer (by the way the download you linked to in your previous post was the exact same page where I got my MSXML 4 installer previously). I did however find both those files in the C:/Windows/SysWOW64 folder. After a little 'test' where I supposedly uninstalled the MSXML 4 using the original installer, to see if those files disappeared form the SysWOW64 folder, they didn't! They're still there so they weren't installed there by the conventional installer 0_o
This makes things even more weird, since first; All the info I read on MSXML 4.0 says it is 32-bit only, so there shouldn't be any reason for the dll files to be in the 64-bit folder; second, if those files weren't put there by the installer, and the installer isn't putting the dll files where they actually should be (the System32 folder) then where is it installing them?? o_O
I was thinking, as a method of trying to solve the problem, if I should extract the dll files from the cab and copy them myself to the System32 folder; or do you think this is not advisable?

Hi Leo:

I have never had to deal with this error; but this thread may offer some insights and a fix ...that I have not yet encountered elsewhere: :idea:


I am speculating that the "SDK" referred to in the above thread is the FS2004 SDK ? :scratchch

Yet another "OOPS" at FSDeveloper during the ongoing website "upgrade" process for the linked page in the thread cited above: :stirthepo

Oops! We ran into some problems.

The requested page could not be found.


PS: Hopefully Leo will not have to undergo the dreaded "down-and-dirty" search-and-destroy uninstall of all things MSXML4.x:



...before then re-installing the above cited MSXML4 SP3 (again). :yikes:

Last edited:
Many of the links to the various forums have changed with the new format; I don't think there is a way to fix those?
Take a guess how many here quit posting at AVSIM and SOH etc. due to failing to maintain a 'knowledge base' by converting existing links ? :alert:


Here is another 'possible' solution for FS9 development: :idea:




"MSXML 4.0 Service Pack 2 (Microsoft XML Core Services)

Download: https://www.microsoft.com/en-us/download/confirmation.aspx?id=19662

MSXML 4.0 Service Pack 2 (SP2) is a complete replacement of MSXML 4.0 and MSXML 4.0 Service Pack 1 (SP1). MSXML 4.0 SP2 provides a number of security and bug fixes. MSXML 4.0 SP2 does not replace MSXML 3.0."

CAVEAT: Be certain to MANUALLY "register" the pertinent files with Windows' "regsvr32" utility, then re-boot Windows afterwards !


Last edited:
Hey Gary,

Well I'm getting frustrated here... :banghead:
I tried all methods and links you referred to previously, and nothing changed. I even extracted and copied myself the dll files to the C:\Windows\System32 directory, and successfully registered msxml4.dll with the cmd prompt listed here https://superuser.com/questions/298142/how-to-register-a-dll-file-in-windows-7
After restarting Windows and trying to compile the model again in MCX, nothing changed! still the same errors; so I read more about the issue and noticed people in that link I posted now mentoining that SysWOW64 folder is actually wjere 32 bit stuff running on 64 bit is actually put (that would explain why msxml4 was already there I guess..?) and so I decided to try and register the dll, but this time in the SysWOW64 folder, but no matter what I do, cmd cd, popd, cd C:, I can't seem to be able to 'leave' the default C:\Windows\System32 folder in cmd.exe so that I could try to register the dll in that folder! :banghead::banghead::banghead::banghead::banghead:

EDIT: Nevermind, my dumb self thought that in the line "e) Type cd .. press enter" the '..' meant a pause/wait and were not part of the command :oops:
I really am an extreme n00b when it comes to 'code' and commandlines :rotfl: I feel just like this: http://i0.kym-cdn.com/photos/images/newsfeed/000/234/765/b7e.jpg

EDIT 2: registered the dll in the SysWOW64 folder, still nothing changed in MCX, same errors occur :censored:

Last edited:
Thanks Pyscen,
But unfortunately that was the exact first thing I did when trying to troubleshoot this, download the installer from that very same link and try to install msxml4, which changed nothing! And apoarently I already had it installed in the SysWOW64 folder, though the errors still happened ehen compiling..
Lots of stuff and ideas have since been tried but to no avail.. :(
Still thanks for taking the time to reply!

What error are getting again... is it the same as the original post... also... you might want to try installing by right-clicking and with admin rights... do not look around and think the installer isn't working that is silly. There could be associated files or needed that MSXML needs...
The errors are the same as in the OP yes, and I have installed always as admin. Also got all associated files I read about on every post and website I visited about this.
I considered that the installer isn't doing it's job correctly because, if it is, then why after I install, there are no dll files in the Windows/System32 folder? Is it because they are supposed to be in the SysWOW64 folder instead? (where there actually was already an msxml4 dll file before I tried to start installing and uninstalling msxml) Then if that is the case then why after I uninstall the dll files are still there?
Is it a registry problem? Been there done that, on both folders! Still the exact same errors occur in the bgl compilation phase as they did when I first reported this issue! Even tried doing it with a completely different model, just in case; same result :banghead:
There just isn't anything else I could find that could be causing this, or more solutions for this issue!

Just thought I'd add that I've just tested editing an airport, adding some buildings in ADE9 (since most of these errors were reported by people when using ADE), and it also comes out with the same errors as MCX when I try to compile the airport to bgl files... :banghead:
I never had these errors with ADE before, and I've used it extensively. I haven't used ADE in a while though (8+ months) so what I can infer is that I previously had msxml4 installed flawlessly, but since then, somehow or something caused it, or it's installation to be corrupt, damaged, altered, or what not.. :(
Anyone have any new ideas that might help please? :)

The files most likely not fully uninstalling because there other applications needing them... shared... therefore will not delete all... uninstalling may have caused corruption as well...

Please show more of the event log in MCX Please
All the relevant lines in the event log are shown in that pic, but nevertheless, I started my computer, opened MCX, imported the model and went straight to compiling, and the attachment in this post is the full event log of that period.
The warnings regarding the texture being in jpg I disregard because I have previously converted them to bmp; and the errors with the compiler occurred anyways after converting them.
Regarding your observation about other apps needing the file, I will try to simply restart, uninstall and install the msxml, restartng again and see if that solves it.
Thanks Pyscen



  • event_log.PNG
    67.4 KB · Views: 457

I uninstalled msxml4 through Control panel>Programs and features and that did make the dll files that weren't 'going away' with the installers I downloaded, disappear from the SysWOW64 folder.
So then I restarted, and using the same installer as the one in the link you first provided I installed. Then I restarted again and tried compiling something in ADE; no joy... So I restarted again, and manually registered the dll in the command prompt as admin. One more restart and I tried to compile something again in ADE, same errors :banghead::banghead::banghead::banghead:
What else is there to do?? And why would this happen now when I always used ADE with none of these issues before?!
And not only can't I use MCX for what I wanted, I now also can't use ADE! :mad:
I'm really at a loss now :(

EDIT: Uninstalled msxml again and tried instead installing this version: https://www.microsoft.com/en-us/download/details.aspx?id=7434&6B49FDFB-8E5B-4B07-BC31-15695C5A2143=1
Noticed in Programs & Features that the version I had previously for install, the same one GaryGB and then Pyscen linked was version 4.30.2100.0 whereas this one is version 4.30.2107.0
Installed, registered in command prompt and STILL the same errors occur :banghead:
Getting close to consider nuking my whole Windows setup and start over re-installing everything :( :( :(

Last edited:
I found this thread in the ADE section of the forums, and after reading this post https://www.fsdeveloper.com/forum/t...-msxml-4-bad-install.73172/page-3#post-221527 and all subsequent ones I found a solution that worked for me!
I found there that what I had in common with arcueil was that both of us installed ALL the FS9 SDK's before the compiler errors started showing up! :idea:
The culprit was the ATC voicepack SDK which for some reason completely :censored: up the msxml4.dll registry!
Completely uninstalling that SDK, manually removing msxml4.dll & msxml4r.dll from the SysWOW64 folder to any other folder (desktop for example), unregistering them with CommandPromt as admin, then deleting them, followed by installing both the MSXML4 SP3 https://www.microsoft.com/en-us/download/details.aspx?id=15697 & then the update https://www.microsoft.com/en-us/download/details.aspx?id=7434&6B49FDFB-8E5B-4B07-BC31-15695C5A2143=1 & restarting my computer; got both ADE and MCX finally working and compiling stuff flawlessly!
I feel so bad like punching the person who screwed up the msxml4 installation with FS9 ATC SDK in the face for making me waste almost 2 days of time around this crap! :mad::mad::mad::mad::censored::censored::censored:
But I'm just happy it's finally over and I can now carry on with my projects... :cool:
end rant

Thank you very much to all who took the time to help me with this issue! :)

Last edited: